summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-08-04 14:14:51 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-08-04 14:14:51 +0300
commit116bed619a3c5d40dd0dd30c3d601d5d1de0159e (patch)
tree9662a36dac1827a0afe85531a0e227ac9d94e01d /app-editors/vscode
parentsys-libs/binutils-libs: 2.41 patchlevel 2 bump (2.41-r1) (diff)
downloadgentoo-116bed619a3c5d40dd0dd30c3d601d5d1de0159e.tar.gz
gentoo-116bed619a3c5d40dd0dd30c3d601d5d1de0159e.tar.bz2
gentoo-116bed619a3c5d40dd0dd30c3d601d5d1de0159e.zip
app-editors/vscode: add 1.81.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors/vscode')
-rw-r--r--app-editors/vscode/Manifest3
-rw-r--r--app-editors/vscode/vscode-1.81.0.ebuild121
2 files changed, 124 insertions, 0 deletions
diff --git a/app-editors/vscode/Manifest b/app-editors/vscode/Manifest
index c8d18e51a94b..176c33698b85 100644
--- a/app-editors/vscode/Manifest
+++ b/app-editors/vscode/Manifest
@@ -4,3 +4,6 @@ DIST vscode-1.80.1-arm64.tar.gz 131637149 BLAKE2B 1fdcbbbf0111ec61fd280a5c75eb58
DIST vscode-1.80.2-amd64.tar.gz 135322981 BLAKE2B 8de8f7c0fbdc7a2085cbeb779936bab465c129531d864f0bdb3b71c817efe8f8b90df2776bebe45b4fe7d7c1db7df38b2f62c926fe949ec377c85e1056136290 SHA512 1d8b44b49e26aa1d54aa9211a4b72989be34bc1609801b64c41f3803d6e36650c432e08afe4143bbd9930559ceebc8479940cd0f68cd8653418f6317c2787518
DIST vscode-1.80.2-arm.tar.gz 119950045 BLAKE2B e3e595f062930c19974a7983fa339b822eb5c83758a40c1671e439befc7f96480f6603b7b5bf7f74322a16fb7995e0c05e8c87ddc9bc02eef3833f52cecf378a SHA512 561979576a8a4a610aadd4dcbedc0da6528f49b6ad52c93004c4e1b5ba5c908a443c8a63e1f3e31a5692a42c9a07e3c7de47b1cc52435d416357f6c9f65cc364
DIST vscode-1.80.2-arm64.tar.gz 131631847 BLAKE2B 0e6cbf72dc2720a1685d569940cf1a3386dc00180c555bfc2b1719ead85347a840cd7bdaea446d18ba6caf6590f62eb7b36a3039efc1e361c162148eee6ece9e SHA512 e60ba2b8c432be11acf29702d727afe017513e3d94f424396ab5b508c2bce1f2afd09f3af9d647fc5ff390fdcc6dd3f1d2ecb646722b79acf0ff00134b6f2001
+DIST vscode-1.81.0-amd64.tar.gz 128464266 BLAKE2B c3d2c19062d9999363db60f9356c075518b9de5a9364bd396585f0fb185362e603db9ecb37fd1ded2bc09c0a760ea7973a8b0e26cff84fb9e78cb72ca7da695b SHA512 7eccf494c6e36137ad5b6f7aecef4905c2bad2e9d10954904f9766f80b591ce6ee7f7ee29d02b30744168805ec242d06dd459712caf5e3a9dc3eaf33a3e1571b
+DIST vscode-1.81.0-arm.tar.gz 113352419 BLAKE2B 5597a92af36d4f5caedf00fca528b87735756b251b67565f720214fc72424c52aadd914f10cf3bab48a0bf9b94c3e91a097f7d40617e46194243f845cc5eb25c SHA512 cc09c865d35aec1842cc0200875a429b66fd7d936a4ea0e2708808495504758bb12a07e22905bae2584a9122e266a4e0a09b6f72a84983270b74c4b5b91cf83b
+DIST vscode-1.81.0-arm64.tar.gz 124958839 BLAKE2B 5e4595bd42736a7d2a9d0d97897d9f1a28fabe006a90ac0904e47edac4cefd956b63d23dc042db95ac24bcf96579dfe1ca8f5c7c2a3753e944e5a36ffcc08c84 SHA512 4dc7fd77954cdd4be3b7722bbbdb2eb592deb38953339d9e57552d5d23fb984407a34511ddeaaeb44e24af7dc2f9742aad7f78ce7a1884bb197f83fea6598cc7
diff --git a/app-editors/vscode/vscode-1.81.0.ebuild b/app-editors/vscode/vscode-1.81.0.ebuild
new file mode 100644
index 000000000000..5a160dc35b29
--- /dev/null
+++ b/app-editors/vscode/vscode-1.81.0.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="Multiplatform Visual Studio Code from Microsoft"
+HOMEPAGE="https://code.visualstudio.com"
+SRC_URI="
+ amd64? ( https://update.code.visualstudio.com/${PV}/linux-x64/stable -> ${P}-amd64.tar.gz )
+ arm? ( https://update.code.visualstudio.com/${PV}/linux-armhf/stable -> ${P}-arm.tar.gz )
+ arm64? ( https://update.code.visualstudio.com/${PV}/linux-arm64/stable -> ${P}-arm64.tar.gz )
+"
+S="${WORKDIR}"
+
+RESTRICT="mirror strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ Microsoft-vscode
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ sys-apps/util-linux
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscode/bin/code-tunnel
+ /opt/vscode/chrome_crashpad_handler
+ /opt/vscode/chrome-sandbox
+ /opt/vscode/code
+ /opt/vscode/libEGL.so
+ /opt/vscode/libffmpeg.so
+ /opt/vscode/libGLESv2.so
+ /opt/vscode/libvk_swiftshader.so
+ /opt/vscode/libvulkan.so*
+ /opt/vscode/resources/app/extensions/*
+ /opt/vscode/resources/app/node_modules.asar.unpacked/*
+ /opt/vscode/swiftshader/libEGL.so
+ /opt/vscode/swiftshader/libGLESv2.so
+"
+
+src_install() {
+ if use amd64; then
+ cd "${WORKDIR}/VSCode-linux-x64" || die
+ elif use arm; then
+ cd "${WORKDIR}/VSCode-linux-armhf" || die
+ elif use arm64; then
+ cd "${WORKDIR}/VSCode-linux-arm64" || die
+ else
+ die "Visual Studio Code only supports amd64, arm and arm64"
+ fi
+
+ # Cleanup
+ rm -r ./resources/app/ThirdPartyNotices.txt || die
+
+ # Disable update server
+ sed -e "/updateUrl/d" -i ./resources/app/product.json || die
+
+ # Install
+ pax-mark m code
+ mkdir -p "${ED}/opt/${PN}" || die
+ cp -r . "${ED}/opt/${PN}" || die
+ fperms 4711 /opt/${PN}/chrome-sandbox
+
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/vscode"
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/code"
+ dosym -r "/opt/${PN}/bin/code-tunnel" "usr/bin/code-tunnel"
+ domenu "${FILESDIR}/vscode.desktop"
+ domenu "${FILESDIR}/vscode-url-handler.desktop"
+ domenu "${FILESDIR}/vscode-wayland.desktop"
+ domenu "${FILESDIR}/vscode-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscode.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "keyring support inside vscode" "virtual/secret-service"
+}