summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-10 11:24:12 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-11 18:49:16 +1000
commit20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3 (patch)
tree717d375d4bc34b50cfb78c9712a992489ed8d73b /app-editors
parenteclass: update rust usedep handling; address feedback (diff)
downloadgentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.tar.gz
gentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.tar.bz2
gentoo-20c78cda3f6a7edfb22c791e0e16c5d5ca20bdb3.zip
*/*: fix rust eclass usedep/mutlilib handling; inherit order
The rust eclass has been updated to directly inject a required MULTILIB_USEDEP when requested. RUST_USEDEP has been renamed to RUST_REQUIRED_USE to be consistent with other eclasses. llvm-r1 should be imported after cargo and the eclass now enables this. Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/zed/zed-0.155.2-r1.ebuild2
-rw-r--r--app-editors/zed/zed-0.159.10-r1.ebuild2
-rw-r--r--app-editors/zed/zed-0.160.7-r1.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/app-editors/zed/zed-0.155.2-r1.ebuild b/app-editors/zed/zed-0.155.2-r1.ebuild
index 7ac2746fed38..d48523bf4511 100644
--- a/app-editors/zed/zed-0.155.2-r1.ebuild
+++ b/app-editors/zed/zed-0.155.2-r1.ebuild
@@ -34,7 +34,7 @@ LLVM_COMPAT=( 18 )
RUST_MIN_VER="1.80.1"
RUST_NEEDS_LLVM=1
-inherit llvm-r1 cargo check-reqs desktop flag-o-matic toolchain-funcs xdg
+inherit cargo check-reqs desktop flag-o-matic llvm-r1 toolchain-funcs xdg
DESCRIPTION="The fast, collaborative code editor"
HOMEPAGE="https://zed.dev https://github.com/zed-industries/zed"
diff --git a/app-editors/zed/zed-0.159.10-r1.ebuild b/app-editors/zed/zed-0.159.10-r1.ebuild
index 6b5c07a29c86..3fc90c2cbb66 100644
--- a/app-editors/zed/zed-0.159.10-r1.ebuild
+++ b/app-editors/zed/zed-0.159.10-r1.ebuild
@@ -58,7 +58,7 @@ LLVM_COMPAT=( 18 )
RUST_MIN_VER="1.80.1"
RUST_NEEDS_LLVM=1
-inherit llvm-r1 cargo check-reqs desktop flag-o-matic toolchain-funcs xdg
+inherit cargo check-reqs desktop flag-o-matic llvm-r1 toolchain-funcs xdg
DESCRIPTION="The fast, collaborative code editor"
HOMEPAGE="https://zed.dev https://github.com/zed-industries/zed"
diff --git a/app-editors/zed/zed-0.160.7-r1.ebuild b/app-editors/zed/zed-0.160.7-r1.ebuild
index 6b5c07a29c86..3fc90c2cbb66 100644
--- a/app-editors/zed/zed-0.160.7-r1.ebuild
+++ b/app-editors/zed/zed-0.160.7-r1.ebuild
@@ -58,7 +58,7 @@ LLVM_COMPAT=( 18 )
RUST_MIN_VER="1.80.1"
RUST_NEEDS_LLVM=1
-inherit llvm-r1 cargo check-reqs desktop flag-o-matic toolchain-funcs xdg
+inherit cargo check-reqs desktop flag-o-matic llvm-r1 toolchain-funcs xdg
DESCRIPTION="The fast, collaborative code editor"
HOMEPAGE="https://zed.dev https://github.com/zed-industries/zed"