summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2024-08-17 13:12:30 -0400
committerMike Gilbert <floppym@gentoo.org>2024-08-17 13:13:10 -0400
commit2a2d6fbe8ef24b0c33e04af4e92148af77da1f6f (patch)
tree7e7d2fb3919cd68561f2d7b4e0103171f87055b7 /app-editors
parentdev-python/griffe: Bump to 1.1.0 (diff)
downloadgentoo-2a2d6fbe8ef24b0c33e04af4e92148af77da1f6f.tar.gz
gentoo-2a2d6fbe8ef24b0c33e04af4e92148af77da1f6f.tar.bz2
gentoo-2a2d6fbe8ef24b0c33e04af4e92148af77da1f6f.zip
app-editors/neovim: pass full path in LUA_PRG
Closes: https://bugs.gentoo.org/936946 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/neovim/neovim-0.10.0-r1.ebuild3
-rw-r--r--app-editors/neovim/neovim-0.10.0.ebuild3
-rw-r--r--app-editors/neovim/neovim-0.10.1.ebuild3
-rw-r--r--app-editors/neovim/neovim-9999.ebuild3
4 files changed, 4 insertions, 8 deletions
diff --git a/app-editors/neovim/neovim-0.10.0-r1.ebuild b/app-editors/neovim/neovim-0.10.0-r1.ebuild
index 399df8c4faf1..cae241418746 100644
--- a/app-editors/neovim/neovim-0.10.0-r1.ebuild
+++ b/app-editors/neovim/neovim-0.10.0-r1.ebuild
@@ -89,13 +89,12 @@ src_prepare() {
}
src_configure() {
- ln -s "${BROOT}"/usr/bin/luajit "${BUILD_DIR}"/luajit || die
# TODO: Investigate USE_BUNDLED, doesn't seem to be needed right now
local mycmakeargs=(
# appends -flto
-DENABLE_LTO=OFF
-DPREFER_LUA=$(usex lua_single_target_luajit no "$(lua_get_version)")
- -DLUA_PRG="${ELUA}"
+ -DLUA_PRG="${LUA}"
)
cmake_src_configure
}
diff --git a/app-editors/neovim/neovim-0.10.0.ebuild b/app-editors/neovim/neovim-0.10.0.ebuild
index 1ae8d920bf61..8c1e075d2ee6 100644
--- a/app-editors/neovim/neovim-0.10.0.ebuild
+++ b/app-editors/neovim/neovim-0.10.0.ebuild
@@ -80,13 +80,12 @@ src_prepare() {
}
src_configure() {
- ln -s "${BROOT}"/usr/bin/luajit "${BUILD_DIR}"/luajit || die
# TODO: Investigate USE_BUNDLED, doesn't seem to be needed right now
local mycmakeargs=(
# appends -flto
-DENABLE_LTO=OFF
-DPREFER_LUA=$(usex lua_single_target_luajit no "$(lua_get_version)")
- -DLUA_PRG="${ELUA}"
+ -DLUA_PRG="${LUA}"
)
cmake_src_configure
}
diff --git a/app-editors/neovim/neovim-0.10.1.ebuild b/app-editors/neovim/neovim-0.10.1.ebuild
index 430fcb85153c..d7cc51448a72 100644
--- a/app-editors/neovim/neovim-0.10.1.ebuild
+++ b/app-editors/neovim/neovim-0.10.1.ebuild
@@ -90,13 +90,12 @@ src_prepare() {
}
src_configure() {
- ln -s "${BROOT}"/usr/bin/luajit "${BUILD_DIR}"/luajit || die
# TODO: Investigate USE_BUNDLED, doesn't seem to be needed right now
local mycmakeargs=(
# appends -flto
-DENABLE_LTO=OFF
-DPREFER_LUA=$(usex lua_single_target_luajit no "$(lua_get_version)")
- -DLUA_PRG="${ELUA}"
+ -DLUA_PRG="${LUA}"
)
cmake_src_configure
}
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index ee6477ed945e..a322637e75c8 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -90,13 +90,12 @@ src_prepare() {
}
src_configure() {
- ln -s "${BROOT}"/usr/bin/luajit "${BUILD_DIR}"/luajit || die
# TODO: Investigate USE_BUNDLED, doesn't seem to be needed right now
local mycmakeargs=(
# appends -flto
-DENABLE_LTO=OFF
-DPREFER_LUA=$(usex lua_single_target_luajit no "$(lua_get_version)")
- -DLUA_PRG="${ELUA}"
+ -DLUA_PRG="${LUA}"
)
cmake_src_configure
}