summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDongsu Park <dpark@linux.microsoft.com>2022-02-18 12:27:16 +0100
committerSam James <sam@gentoo.org>2022-02-18 17:56:32 +0000
commit90d47914d37a74bf090f7c5fab43bb8f5084b9ae (patch)
tree98448634647f003b646d8bca03ab56ea156c3f86 /app-editors
parentsys-apps/hwinfo: Stabilize 21.80 ppc, #833612 (diff)
downloadgentoo-90d47914d37a74bf090f7c5fab43bb8f5084b9ae.tar.gz
gentoo-90d47914d37a74bf090f7c5fab43bb8f5084b9ae.tar.bz2
gentoo-90d47914d37a74bf090f7c5fab43bb8f5084b9ae.zip
app-editors/vim: fix conflicts in 8.2.{4285,4328}
We fixed defaults.vim installation conflicts in 49adc5f0272e40ac608a89d268ee12811fcca384, but not for 8.2.4285 and 8.2.4328. Fix the issue for the versions. Bug: https://bugs.gentoo.org/830177 Signed-off-by: Dongsu Park <dpark@linux.microsoft.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim/vim-8.2.4285.ebuild6
-rw-r--r--app-editors/vim/vim-8.2.4328.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/app-editors/vim/vim-8.2.4285.ebuild b/app-editors/vim/vim-8.2.4285.ebuild
index a15f1260d55d..2b7c3b0992cc 100644
--- a/app-editors/vim/vim-8.2.4285.ebuild
+++ b/app-editors/vim/vim-8.2.4285.ebuild
@@ -320,8 +320,10 @@ src_install() {
# Fix an issue of missing defaults.vim when USE=minimal.
if use minimal ; then
- insinto ${vimfiles}
- doins runtime/defaults.vim
+ if [[ ! -f "${vimfiles}/defaults.vim" ]]; then
+ insinto ${vimfiles}
+ doins runtime/defaults.vim
+ fi
fi
domenu runtime/vim.desktop
diff --git a/app-editors/vim/vim-8.2.4328.ebuild b/app-editors/vim/vim-8.2.4328.ebuild
index a15f1260d55d..2b7c3b0992cc 100644
--- a/app-editors/vim/vim-8.2.4328.ebuild
+++ b/app-editors/vim/vim-8.2.4328.ebuild
@@ -320,8 +320,10 @@ src_install() {
# Fix an issue of missing defaults.vim when USE=minimal.
if use minimal ; then
- insinto ${vimfiles}
- doins runtime/defaults.vim
+ if [[ ! -f "${vimfiles}/defaults.vim" ]]; then
+ insinto ${vimfiles}
+ doins runtime/defaults.vim
+ fi
fi
domenu runtime/vim.desktop