summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-23 22:02:03 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-23 23:06:53 +0100
commitfb2ccb786686a95e6d480f4e86a6104a7015feba (patch)
tree2f1c9d0663aa8f6e9baba3ce9b0bd4371b16ccc3 /app-emacs/corfu
parentapp-emacs/corfu: drop old 1.0 (diff)
downloadgentoo-fb2ccb786686a95e6d480f4e86a6104a7015feba.tar.gz
gentoo-fb2ccb786686a95e6d480f4e86a6104a7015feba.tar.bz2
gentoo-fb2ccb786686a95e6d480f4e86a6104a7015feba.zip
app-emacs/corfu: bump to 1.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/corfu')
-rw-r--r--app-emacs/corfu/Manifest1
-rw-r--r--app-emacs/corfu/corfu-1.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/corfu/Manifest b/app-emacs/corfu/Manifest
index 26e3fd914c46..e2d060ea14b8 100644
--- a/app-emacs/corfu/Manifest
+++ b/app-emacs/corfu/Manifest
@@ -1 +1,2 @@
DIST corfu-1.1.tar.gz 49047 BLAKE2B aa1161f300f8a6ebf3c8ef5a0bc6a9737ed67799a46afa8a79809b5faef887ad75237b38ff29f34f5b8456db177b9527945c2c16b9cb9d725ccfbb9b600007d8 SHA512 6775f29ccc22656787664b6766416582d6e0e33497e31f19781ea443132604c84d488d66a90b5c58f99456124d3f5228dbdab5759741edea56689521587d8d21
+DIST corfu-1.2.tar.gz 49307 BLAKE2B 69dbc020671ac83a8c858030079f53eb2dd16a4b8a418386f310b56ffc4bc74da87a1f87355daf615eb120962186ae2210b9c1237d62e282b4436cb8433e959e SHA512 b1528e71bc03a5a06428e58009ea4e1bd68d9bc0f38181da910f5a633b35545642dc9fe8e2e39316f2b9bce7c3fc61418225f8243fb86ec2c2d96f7c0e88900b
diff --git a/app-emacs/corfu/corfu-1.2.ebuild b/app-emacs/corfu/corfu-1.2.ebuild
new file mode 100644
index 000000000000..d8351fe993cc
--- /dev/null
+++ b/app-emacs/corfu/corfu-1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Completion Overlay Region FUnction"
+HOMEPAGE="https://github.com/minad/corfu/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.3.4"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el . || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}