summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-23 22:08:10 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-23 23:06:53 +0100
commite34584b2495310983c4ce0c96e9c7aa3309fd6ba (patch)
tree016b7951f59d5b86a8f4ddba241812f489fc616c /app-emacs/doom-modeline/doom-modeline-4.1.0.ebuild
parentapp-emacs/corfu: bump to 1.2 (diff)
downloadgentoo-e34584b2495310983c4ce0c96e9c7aa3309fd6ba.tar.gz
gentoo-e34584b2495310983c4ce0c96e9c7aa3309fd6ba.tar.bz2
gentoo-e34584b2495310983c4ce0c96e9c7aa3309fd6ba.zip
app-emacs/doom-modeline: bump to 4.1.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/doom-modeline/doom-modeline-4.1.0.ebuild')
-rw-r--r--app-emacs/doom-modeline/doom-modeline-4.1.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/doom-modeline/doom-modeline-4.1.0.ebuild b/app-emacs/doom-modeline/doom-modeline-4.1.0.ebuild
new file mode 100644
index 000000000000..e35cedd72dc5
--- /dev/null
+++ b/app-emacs/doom-modeline/doom-modeline-4.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Fancy and fast mode-line for Emacs inspired by minimalism design"
+HOMEPAGE="https://seagle0128.github.io/doom-modeline/
+ https://github.com/seagle0128/doom-modeline/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/seagle0128/${PN}.git"
+else
+ SRC_URI="https://github.com/seagle0128/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ app-emacs/compat
+ app-emacs/nerd-icons
+ app-emacs/shrink-path
+"
+BDEPEND="${RDEPEND}"
+
+elisp-enable-tests ert test
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}