summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-11-01 00:43:38 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-11-01 00:46:09 +0100
commit2f8e77b4f60f74a708ce326005f6c2c69be57233 (patch)
tree165f256f88783284a045e2d58bd71cc6ed3b2137 /app-emacs/emacs-eat
parentwww-apps/nextcloud: stabilize 25.0.12 for amd64, x86 (diff)
downloadgentoo-2f8e77b4f60f74a708ce326005f6c2c69be57233.tar.gz
gentoo-2f8e77b4f60f74a708ce326005f6c2c69be57233.tar.bz2
gentoo-2f8e77b4f60f74a708ce326005f6c2c69be57233.zip
app-emacs/emacs-eat: new package; add 0.9.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/emacs-eat')
-rw-r--r--app-emacs/emacs-eat/Manifest1
-rw-r--r--app-emacs/emacs-eat/emacs-eat-0.9.2.ebuild63
-rw-r--r--app-emacs/emacs-eat/files/50emacs-eat-gentoo.el4
-rw-r--r--app-emacs/emacs-eat/metadata.xml24
4 files changed, 92 insertions, 0 deletions
diff --git a/app-emacs/emacs-eat/Manifest b/app-emacs/emacs-eat/Manifest
new file mode 100644
index 000000000000..8ebc6ce930b1
--- /dev/null
+++ b/app-emacs/emacs-eat/Manifest
@@ -0,0 +1 @@
+DIST emacs-eat-0.9.2.tar.gz 274950 BLAKE2B 2b0378a20d1fec511c7b24e4e5cc1937bb8b01f4a0a76f794d847d77de54fb87bc0806082a2ceeb3793eb034d2e0b1aa916441b5b931e00e935d9399b1c84e14 SHA512 69db9aef6ba4037561bb2a344878ece7912140ff42a4c285b355ef2ef2351282d048af78949fe52959c6e5543f8a9a63bd07fc931b802abaa981effbb65e9c20
diff --git a/app-emacs/emacs-eat/emacs-eat-0.9.2.ebuild b/app-emacs/emacs-eat/emacs-eat-0.9.2.ebuild
new file mode 100644
index 000000000000..4f2a6cced758
--- /dev/null
+++ b/app-emacs/emacs-eat/emacs-eat-0.9.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emulate A Terminal, in a region, in a buffer and in Eshell"
+HOMEPAGE="https://codeberg.org/akib/emacs-eat/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://codeberg.org/akib/${PN}.git"
+else
+ SRC_URI="https://codeberg.org/akib/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( ChangeLog NEWS README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.2
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+elisp-enable-tests ert . -l eat-tests.el
+
+src_compile() {
+ rm -r terminfo || die
+ emake EMACS="${EMACS}" EMACSFLAGS="${EMACSFLAGS}"
+
+ elisp-compile term/eat.el
+
+ elisp-make-autoload-file
+}
+
+src_install() {
+ rm eat-tests.el || die
+ elisp_src_install
+
+ insinto "${SITELISP}/${PN}"
+ doins -r term
+
+ insinto "${SITEETC}/${PN}"
+ doins -r integration
+ doins -r terminfo
+
+ insinto /usr/share
+ doins -r terminfo
+
+ doinfo eat.info
+}
diff --git a/app-emacs/emacs-eat/files/50emacs-eat-gentoo.el b/app-emacs/emacs-eat/files/50emacs-eat-gentoo.el
new file mode 100644
index 000000000000..ba961a5100d4
--- /dev/null
+++ b/app-emacs/emacs-eat/files/50emacs-eat-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "emacs-eat-autoloads" nil t)
+(setq eat-term-shell-integration-directory "@SITEETC@/integration")
+(setq eat-term-terminfo-directory "@SITEETC@/terminfo")
diff --git a/app-emacs/emacs-eat/metadata.xml b/app-emacs/emacs-eat/metadata.xml
new file mode 100644
index 000000000000..01dd6db7d03a
--- /dev/null
+++ b/app-emacs/emacs-eat/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Eat's name self-explanatory, it stands for "Emulate A Terminal". Eat is a
+ terminal emulator. It can run most (if not all) full-screen terminal
+ programs, including Emacs. It is pretty fast, more than three times faster
+ than Term, despite being implemented entirely in Emacs Lisp. So fast that
+ you can comfortably run Emacs inside Eat, or even use your Emacs as a
+ terminal multiplexer. It has many features that other Emacs terminal
+ emulator still don't have, for example Sixel support, complete mouse
+ support, shell integration, etc. It flickers less than other Emacs terminal
+ emulator, so you get more performance and a smoother experience.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://codeberg.org/akib/emacs-eat/issues/</bugs-to>
+ <remote-id type="codeberg">akib/emacs-eat</remote-id>
+ </upstream>
+</pkgmetadata>