summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-07 09:43:05 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-07 09:45:55 +0200
commit8ccdea6752be5e1e8948c3c6274389a811ae3888 (patch)
tree626dce1dd817536a0a0ce477f20967e735cc5109 /app-emacs/ert-runner
parentapp-crypt/jitterentropy: add 3.6.0 (diff)
downloadgentoo-8ccdea6752be5e1e8948c3c6274389a811ae3888.tar.gz
gentoo-8ccdea6752be5e1e8948c3c6274389a811ae3888.tar.bz2
gentoo-8ccdea6752be5e1e8948c3c6274389a811ae3888.zip
app-emacs/ert-runner: fix ert-runner test launcher
Closes: https://bugs.gentoo.org/941096 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/ert-runner')
-rw-r--r--app-emacs/ert-runner/ert-runner-0.8.0-r1.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/app-emacs/ert-runner/ert-runner-0.8.0-r1.ebuild b/app-emacs/ert-runner/ert-runner-0.8.0-r1.ebuild
index 2124baa14fb0..79295684f877 100644
--- a/app-emacs/ert-runner/ert-runner-0.8.0-r1.ebuild
+++ b/app-emacs/ert-runner/ert-runner-0.8.0-r1.ebuild
@@ -54,7 +54,18 @@ SITEFILE="50${PN}-gentoo.el"
src_prepare() {
elisp_src_prepare
- sed "s|@SITELISP@|${EPREFIX}${SITELISP}/${PN}|" -i "./bin/${PN}" || die
+ # There are two "ert-runner" launchers,
+ # the one in "${S}" will be installed,
+ # the one in ./bin/ert-runner will be used only for tests.
+
+ # For later install.
+ sed "./bin/${PN}" \
+ -e "s|@SITELISP@|${EPREFIX}${SITELISP}/${PN}|" \
+ > "./${PN}.bash" \
+ || die
+
+ # For tests.
+ sed -i "./bin/${PN}" -e "s|@SITELISP@|${S}|" || die
}
src_compile() {
@@ -75,13 +86,13 @@ src_test() {
chmod +x "${T}/bin/cask" || die
local -x PATH="${T}/bin:${PATH}" || die
- edo ecukes --debug --reporter spec --script --verbose features
+ edo ecukes --debug --reporter spec --script --verbose ./features
}
src_install() {
elisp_src_install
- elisp-install "${PN}/reporters" reporters/*.el{,c}
+ elisp-install "${PN}/reporters" ./reporters/*.el{,c}
exeinto /usr/bin
- doexe "./bin/${PN}"
+ newexe "./${PN}.bash" "${PN}"
}