summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-26 01:09:33 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-26 03:31:40 +0200
commit64aa24ebc2afa8546090d44db68e8696d507eb1b (patch)
tree8550166d7bf404731c1549e79c480faf667e11b7 /app-emacs/hydra/hydra-0.15.0.ebuild
parentnet-ftp/filezilla: fix indentation QA warning (diff)
downloadgentoo-64aa24ebc2afa8546090d44db68e8696d507eb1b.tar.gz
gentoo-64aa24ebc2afa8546090d44db68e8696d507eb1b.tar.bz2
gentoo-64aa24ebc2afa8546090d44db68e8696d507eb1b.zip
app-emacs/hydra: new package; add version 0.15.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/hydra/hydra-0.15.0.ebuild')
-rw-r--r--app-emacs/hydra/hydra-0.15.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/hydra/hydra-0.15.0.ebuild b/app-emacs/hydra/hydra-0.15.0.ebuild
new file mode 100644
index 000000000000..dcfd674f615e
--- /dev/null
+++ b/app-emacs/hydra/hydra-0.15.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Make Emacs bindings that stick around"
+HOMEPAGE="https://github.com/abo-abo/hydra/"
+SRC_URI="https://github.com/abo-abo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="app-emacs/lv"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.md doc/Changelog.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ rm hydra-test.el{,c} lv.el{,c} || die
+ elisp_src_install
+}