summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-04-05 12:03:23 +0200
committerUlrich Müller <ulm@gentoo.org>2022-04-05 12:04:21 +0200
commit4830511ba1345983b53e000db04ab14cfbe7f541 (patch)
tree173f1950f7f77db5000f5df660ac570a74087ed8 /app-emacs/icicles
parentprofiles/package.mask: mask app-misc/ttysnoop for removal (diff)
downloadgentoo-4830511ba1345983b53e000db04ab14cfbe7f541.tar.gz
gentoo-4830511ba1345983b53e000db04ab14cfbe7f541.tar.bz2
gentoo-4830511ba1345983b53e000db04ab14cfbe7f541.zip
app-emacs/icicles: Fix byte-compilation with Emacs 28
Closes: https://bugs.gentoo.org/836773 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/icicles')
-rw-r--r--app-emacs/icicles/Manifest1
-rw-r--r--app-emacs/icicles/files/icicles-2018.10.15.23738-emacs-28.patch13
-rw-r--r--app-emacs/icicles/icicles-2018.10.15.23738.ebuild21
3 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/icicles/Manifest b/app-emacs/icicles/Manifest
index f1ae1b761b6e..625ea12d5fb3 100644
--- a/app-emacs/icicles/Manifest
+++ b/app-emacs/icicles/Manifest
@@ -1 +1,2 @@
DIST icicles-2018.02.13.23733.tar.xz 697112 BLAKE2B 63b60a74cfcc5b855e9ffbf7a91d0cb561c46ef1a93fb1baca00a0a5462326da983c734bef1943c0f17583aeb065d8fd5d88769eec2dc35f36a59ea4ff86609b SHA512 6c5d2270c735fafa8e2180134fbe7175e1c99cb6ae904a70dbdf1144293bd1ffa84d9e81b1c1b03296348a6b31ebab62ea7981a4b7f5be8bb5238bd143ccb3c0
+DIST icicles-2018.10.15.23738.tar.gz 1007149 BLAKE2B 34cdae2e247fafab9bb6d5472ed15cf108fd0b008a8f19de1742dfe590ff5b1483c5f28eb8e75b92a32c223dfec67d4601ed3392cda5162d1ea84c9d1f940321 SHA512 ede403a53d44451e4f62f54f7da27c6a5632827c4f1985c153f7d03a1b8ea920238dc9ba78896fc416115f53187a6b6d9a0171f8a91fbc7605462eba48e3f5cc
diff --git a/app-emacs/icicles/files/icicles-2018.10.15.23738-emacs-28.patch b/app-emacs/icicles/files/icicles-2018.10.15.23738-emacs-28.patch
new file mode 100644
index 000000000000..32d1a583c018
--- /dev/null
+++ b/app-emacs/icicles/files/icicles-2018.10.15.23738-emacs-28.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/836773
+
+--- icicles/icicles-fn.el
++++ icicles/icicles-fn.el
+@@ -4264,7 +4264,7 @@
+
+
+ (defalias 'icicle-scatter 'icicle-scatter-re)
+-(make-obsolete 'icicle-scatter 'icicle-scatter-re) ; 2018-01-14
++(make-obsolete 'icicle-scatter 'icicle-scatter-re "2018-01-14")
+
+ (defun icicle-scatter-re (string)
+ "Returns a regexp that matches a scattered version of STRING.
diff --git a/app-emacs/icicles/icicles-2018.10.15.23738.ebuild b/app-emacs/icicles/icicles-2018.10.15.23738.ebuild
new file mode 100644
index 000000000000..22221be4fa00
--- /dev/null
+++ b/app-emacs/icicles/icicles-2018.10.15.23738.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+COMMIT="9e9c37d2a54771c635d00d1fe171cef5eab4d95d"
+DESCRIPTION="Minibuffer input completion and cycling"
+HOMEPAGE="https://www.emacswiki.org/emacs/Icicles"
+# Snapshot of https://github.com/emacsmirror/icicles.git
+# PV is <Version>.<Update #> from header of icicles.el
+SRC_URI="https://github.com/emacsmirror/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/${P}-emacs-28.patch )
+SITEFILE="50${PN}-gentoo.el"