summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-02 11:38:38 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-02 11:49:31 +0200
commite53a436eb95f05ae98a4252d6990142bdf43b371 (patch)
treedcb0bea5d2e695ec232f06799e7eb52a688e4c22 /app-emacs/magit
parentapp-emacs/transient: bump to 0.7.6 (diff)
downloadgentoo-e53a436eb95f05ae98a4252d6990142bdf43b371.tar.gz
gentoo-e53a436eb95f05ae98a4252d6990142bdf43b371.tar.bz2
gentoo-e53a436eb95f05ae98a4252d6990142bdf43b371.zip
app-emacs/magit: bump to 4.1.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/magit')
-rw-r--r--app-emacs/magit/Manifest1
-rw-r--r--app-emacs/magit/magit-4.1.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-emacs/magit/Manifest b/app-emacs/magit/Manifest
index d219a2497b66..fa2b19e3e31b 100644
--- a/app-emacs/magit/Manifest
+++ b/app-emacs/magit/Manifest
@@ -1,2 +1,3 @@
DIST magit-4.0.0.tar.gz 676167 BLAKE2B 2adc7388cddc5230615344b3340ae181feaea1e6c174970e11a5d6f6795ecb32581dc12448c1bdfa6ec4144cc4118ace70049ff264a2c29f084cf90aa3f56d69 SHA512 c42dfe78f1f1c5f6cc732a566b820362993763ada7186d1a76ba0deedf7bd91415d502984e4afd6e958ea237b3f351c718a9e588f9734d7afc186793432229f0
DIST magit-4.1.0.tar.gz 673317 BLAKE2B 6457c77f08605e3665b3fadcb4d6bc48d21498e370261d9709305e774de579be4647afb6e598a446a3ddf06e47baef6561a48706609812991a24e3ab2b22d416 SHA512 063c23a7f1a9099d7ec020980be936b30b85756b30bded48264939c5ae7f742820efc3eadc8ba480ad328ca7276a9d35bb168e6b7a42ea8dfa6a2c1e13b8cc90
+DIST magit-4.1.1.tar.gz 674147 BLAKE2B 4878061957f342aa1c76e8f356a59d6e13ceba35dad6ed0adf4ba59484a3cb9585855aaeec91a40f6dddd9bfa53c0ed0733b506c19be70a5b056ba70dbb27f4e SHA512 c1ab5b4dadf11a0eafcb69ac46c7c1aa19595a1a76e0cf3b8afa987e64c4b525007753179da1e146dab89504f1b436e9141c76025019bd1077d2172beab8105b
diff --git a/app-emacs/magit/magit-4.1.1.ebuild b/app-emacs/magit/magit-4.1.1.ebuild
new file mode 100644
index 000000000000..f833ecc12ec4
--- /dev/null
+++ b/app-emacs/magit/magit-4.1.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="A Git porcelain inside Emacs"
+HOMEPAGE="https://magit.vc/
+ https://github.com/magit/magit/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+S="${WORKDIR}/${P}/lisp"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( ../README.md ../docs/AUTHORS.md ../docs/RelNotes )
+ELISP_TEXINFO="../docs/*.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+ >=app-emacs/dash-2.19.1
+ >=app-emacs/transient-0.7.6
+ >=app-emacs/with-editor-3.4.2
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+RDEPEND+="
+ >=dev-vcs/git-2.44.2
+"
+
+src_prepare() {
+ default
+
+ echo "(setq ${PN}-version \"${PV}\")" > "./${PN}-version.el" || die
+}