summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-10-18 20:05:15 +0200
committerUlrich Müller <ulm@gentoo.org>2019-10-18 20:05:49 +0200
commita33ce22f1bea7ad557fcef3f676d00901a2e6d56 (patch)
treea41ef41acb7d61b01b0a51a9648d3704382941ed /app-emacs/matlab/matlab-3.3.6_pre20191010-r1.ebuild
parentapp-portage/gemato: Bump to 14.2 (diff)
downloadgentoo-a33ce22f1bea7ad557fcef3f676d00901a2e6d56.tar.gz
gentoo-a33ce22f1bea7ad557fcef3f676d00901a2e6d56.tar.bz2
gentoo-a33ce22f1bea7ad557fcef3f676d00901a2e6d56.zip
app-emacs/matlab: Generate autoload file.
Closes: https://bugs.gentoo.org/698006 Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/matlab/matlab-3.3.6_pre20191010-r1.ebuild')
-rw-r--r--app-emacs/matlab/matlab-3.3.6_pre20191010-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-emacs/matlab/matlab-3.3.6_pre20191010-r1.ebuild b/app-emacs/matlab/matlab-3.3.6_pre20191010-r1.ebuild
new file mode 100644
index 000000000000..33487fa8e1bb
--- /dev/null
+++ b/app-emacs/matlab/matlab-3.3.6_pre20191010-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="Major modes for MATLAB .m and .tlc files"
+HOMEPAGE="http://matlab-emacs.sourceforge.net/"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+S="${WORKDIR}/matlab-emacs-src"
+SITEFILE="50${PN}-gentoo-3.3.6.el"
+DOCS="README.org INSTALL ChangeLog*"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file matlab-load.el
+}