summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-30 21:40:25 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-31 00:09:27 +0100
commit10baa53465676e7e0afba90c4915bfc408a1a3d2 (patch)
tree30beef5c1d1e17449008f47b1e58ef85a2d34d91 /app-emacs
parentapp-emacs/mastodon: support live (diff)
downloadgentoo-10baa53465676e7e0afba90c4915bfc408a1a3d2.tar.gz
gentoo-10baa53465676e7e0afba90c4915bfc408a1a3d2.tar.bz2
gentoo-10baa53465676e7e0afba90c4915bfc408a1a3d2.zip
app-emacs/mastodon: bump to 1.0.19
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/mastodon/Manifest1
-rw-r--r--app-emacs/mastodon/mastodon-1.0.19.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-emacs/mastodon/Manifest b/app-emacs/mastodon/Manifest
index a8c04ed71c8b..9eff23327a72 100644
--- a/app-emacs/mastodon/Manifest
+++ b/app-emacs/mastodon/Manifest
@@ -1 +1,2 @@
DIST mastodon-1.0.18.tar.gz 160205 BLAKE2B 329d6192e129c6255bb212fe06061ff5623d16030b3f8b9b2aea33e1d0113fa09af934ead8b4695031a4dc0ddc734aa8674ca64bdad6216ee6e8006639f8131f SHA512 5e1162f30e2735a9a6d73b418369ba70476b2f45967c121e0ca9d741d029a8fc2e314fc8ea33cb09036b7b4e0f9d56b8002c4694fefbe0d6923ab8038ec7a192
+DIST mastodon-1.0.19.tar.gz 160533 BLAKE2B 4acf21f6b50296463c8083d237f2ab8f510f3372e0cd63437bc037dba8e3cdac9806ddf4a2e8727d2a39c0b0bef18688c0cce679019ac99cdf88b508830e25ef SHA512 27c56aa073c003b7063acd816230d1e5bf0f353b2d3c0a6cfa861130d4fbfd80bb5189d8bb1e036442f824d85bf96c0db21a927e4840057eaf17fff3114d3526
diff --git a/app-emacs/mastodon/mastodon-1.0.19.ebuild b/app-emacs/mastodon/mastodon-1.0.19.ebuild
new file mode 100644
index 000000000000..38f5552d3c9f
--- /dev/null
+++ b/app-emacs/mastodon/mastodon-1.0.19.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Emacs client for Mastodon, federated microblogging social network"
+HOMEPAGE="https://codeberg.org/martianh/mastodon.el/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://codeberg.org/martianh/mastodon.el.git"
+else
+ SRC_URI="https://codeberg.org/martianh/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}.el/lisp"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/persist
+ app-emacs/request
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( ../README.org )
+ELISP_TEXINFO="../${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"