summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-27 01:12:47 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-27 01:13:08 +0200
commit53277ef48dbfe60be03041e8bfaf7f3ced5acd52 (patch)
tree144a1e515fe72aeac0722f0228f3da8d24f15766 /app-emacs
parentkde-plasma/kdeplasma-addons: backport comic widget metadata parsing fix (diff)
downloadgentoo-53277ef48dbfe60be03041e8bfaf7f3ced5acd52.tar.gz
gentoo-53277ef48dbfe60be03041e8bfaf7f3ced5acd52.tar.bz2
gentoo-53277ef48dbfe60be03041e8bfaf7f3ced5acd52.zip
app-emacs/package-lint: new package; add version 0.16
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/package-lint/Manifest1
-rw-r--r--app-emacs/package-lint/files/50package-lint-gentoo.el1
-rw-r--r--app-emacs/package-lint/files/package-lint-symbol-info-data-directory.patch26
-rw-r--r--app-emacs/package-lint/metadata.xml26
-rw-r--r--app-emacs/package-lint/package-lint-0.16.ebuild34
5 files changed, 88 insertions, 0 deletions
diff --git a/app-emacs/package-lint/Manifest b/app-emacs/package-lint/Manifest
new file mode 100644
index 000000000000..a55a783a16b8
--- /dev/null
+++ b/app-emacs/package-lint/Manifest
@@ -0,0 +1 @@
+DIST package-lint-0.16.tar.gz 224744 BLAKE2B a1d26ae28727e305416498b66da188cbadababc9f415c199eff380dbce4888ee3137b6f13a26147d427142a9d244c784e192d21df3173d0a0c2dde4acb1e8630 SHA512 f5d79b69d37671233614a622cd5fd6c28c230adb0d5b7934ccd6bedc12228adb7bdef6739fdd32be383cefceb65b9538a00f763b49be6499e4b6e3f8b1a34616
diff --git a/app-emacs/package-lint/files/50package-lint-gentoo.el b/app-emacs/package-lint/files/50package-lint-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/package-lint/files/50package-lint-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/package-lint/files/package-lint-symbol-info-data-directory.patch b/app-emacs/package-lint/files/package-lint-symbol-info-data-directory.patch
new file mode 100644
index 000000000000..1b8644976721
--- /dev/null
+++ b/app-emacs/package-lint/files/package-lint-symbol-info-data-directory.patch
@@ -0,0 +1,26 @@
+index 2ecaef5..8178375 100644
+--- a/package-lint.el
++++ b/package-lint.el
+@@ -106,13 +106,15 @@ a backport library shipping the feature and VERSION is an
+ optional minimum version containing the feature.")
+
+ (defconst package-lint-symbol-info
+- (let* ((stdlib-changes (with-temp-buffer
+- (insert-file-contents
+- (expand-file-name "data/stdlib-changes"
+- (if load-file-name
+- (file-name-directory load-file-name)
+- default-directory)))
+- (read (current-buffer))))
++ (let* ((stdlib-changes
++ (with-temp-buffer
++ (insert-file-contents
++ (let ((siteetc-stdlib-changes
++ (expand-file-name "data/stdlib-changes" "@SITEETC@")))
++ (if (file-exists-p siteetc-stdlib-changes)
++ siteetc-stdlib-changes
++ (expand-file-name "data/stdlib-changes" default-directory))))
++ (read (current-buffer))))
+ (info (make-hash-table)))
+ (pcase-dolist (`(,version . ,data) stdlib-changes)
+ (pcase-dolist (`(,syms . ,action)
diff --git a/app-emacs/package-lint/metadata.xml b/app-emacs/package-lint/metadata.xml
new file mode 100644
index 000000000000..ddaf53faef36
--- /dev/null
+++ b/app-emacs/package-lint/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/purcell/package-lint/issues/</bugs-to>
+ <remote-id type="github">purcell/package-lint</remote-id>
+ </upstream>
+ <longdescription>
+ This library provides a linter for the metadata in Emacs Lisp files which
+ are intended to be packages. You can integrate it into your build process.
+ package-lint detects various issues that may make your package
+ uninstallable or unusable for some users, and it warns about significant
+ deviations from the Elisp coding conventions, such as non-compliant symbol
+ naming, and use of reserved keybindings. Among other community uses,
+ package-lint is a prerequisite for submission of packages to MELPA.
+ package-lint can be used standalone, but see also the flycheck-package and
+ package-lint-flymake packages, which both use package-lint to conveniently
+ display packaging errors directly in the buffer while writing elisp
+ packages.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-emacs/package-lint/package-lint-0.16.ebuild b/app-emacs/package-lint/package-lint-0.16.ebuild
new file mode 100644
index 000000000000..16a41eaf585d
--- /dev/null
+++ b/app-emacs/package-lint/package-lint-0.16.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Linting library for Emacs Lisp package metadata"
+HOMEPAGE="https://github.com/purcell/package-lint/"
+SRC_URI="https://github.com/purcell/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+DOCS=( README.md )
+PATCHES=( "${FILESDIR}"/${PN}-symbol-info-data-directory.patch )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITEETC@|${EPREFIX}${SITEETC}/${PN}|" -i ${PN}.el || die
+}
+
+src_install() {
+ elisp-install ${PN} ${PN}{,-flymake}.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ insinto ${SITEETC}/${PN}
+ doins -r data
+}