summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-11-12 19:36:10 +0100
committerUlrich Müller <ulm@gentoo.org>2024-11-12 19:39:11 +0100
commit699359f83cc327fbb34b814a48fb6fafadb2d4a5 (patch)
treea08709ba184924a86afbcf00178882562fdf3a50 /app-emacs
parentmail-mta/msmtp: Stabilize 1.8.27 ppc64, #943317 (diff)
downloadgentoo-699359f83cc327fbb34b814a48fb6fafadb2d4a5.tar.gz
gentoo-699359f83cc327fbb34b814a48fb6fafadb2d4a5.tar.bz2
gentoo-699359f83cc327fbb34b814a48fb6fafadb2d4a5.zip
app-emacs/ebuild-mode: add 1.76
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/ebuild-mode/Manifest1
-rw-r--r--app-emacs/ebuild-mode/ebuild-mode-1.76.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/ebuild-mode/Manifest b/app-emacs/ebuild-mode/Manifest
index 0cdc1d18fecc..849f83ce9878 100644
--- a/app-emacs/ebuild-mode/Manifest
+++ b/app-emacs/ebuild-mode/Manifest
@@ -1,2 +1,3 @@
DIST ebuild-mode-1.72.tar.xz 41968 BLAKE2B 24170aa6f23022f47707445eebbb7272c898fa8ca922d0a1ee57962ccc9feed6ea608661998e3f812a0b5fcc8ce8d8ff0baa890505dad846e0dc4b5c9e0b4236 SHA512 7f2234f9f5053f9588fb25d673dbce10a9d6e5c056ea7dabf04ffe5a0f8da7064b81829229339c5d98ee7ce840eb6c8b9ec24fcfd3dee2d5b798b5e6adb81e10
DIST ebuild-mode-1.75.tar.xz 48592 BLAKE2B 2273357c2736e0952637bb00754f0eff8379b5bd27793dac43d4d17e12affb8e88925ef321bd74709bc1054953f3fe3263b676c9faab93434558f45f55a70b28 SHA512 c00835513db517f07361ffa9fc86e8b268c89126fb1a0c88950e8566fcae296f115e29e6fa371bd93be34d6938e2a828e3382ea0b489a3e72af972b4f7b22e2e
+DIST ebuild-mode-1.76.tar.xz 50404 BLAKE2B 9aeda48858155286c9df2075b61f596723d457ac1592ab581e1589d291db2f54d3c5d81dd610a41506d43d5d90943404a8f74fc4b742d7ed33f4e623930d1fc7 SHA512 e9659878109de92789204d6bd9493465b1d078a5ac5a10937397478a20766bab453bdfc8d3352625570b37b8bf8aadc28369652979032427a1c8d6d13242aa64
diff --git a/app-emacs/ebuild-mode/ebuild-mode-1.76.ebuild b/app-emacs/ebuild-mode/ebuild-mode-1.76.ebuild
new file mode 100644
index 000000000000..8ab41edb1ee4
--- /dev/null
+++ b/app-emacs/ebuild-mode/ebuild-mode-1.76.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp optfeature
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+BDEPEND="sys-apps/texinfo"
+
+DOCS="ChangeLog keyword-generation.sh"
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo-1.72.el"
+
+pkg_postinst() {
+ elisp_pkg_postinst
+ optfeature "ebuild commands support" sys-apps/portage
+ optfeature "additional development tools" dev-util/pkgdev
+ optfeature "ebuild QA utilities" dev-util/pkgcheck
+ optfeature "decode ANSI colors in build.log" app-emacs/tty-format
+ optfeature "XML syntax validation" app-emacs/nxml-gentoo-schemas
+ optfeature "generating HTML from GLEPs" dev-python/docutils-glep
+}