summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2025-01-05 14:29:08 +0100
committerMaciej Barć <xgqt@gentoo.org>2025-01-05 17:21:52 +0100
commit978628396f720043563e4a100b95bf5bca301d7b (patch)
tree016af9535d841e9972db8cae09474870f24b67c0 /app-emacs
parentapp-emacs/forge: drop old 0.4.4-r1 (diff)
downloadgentoo-978628396f720043563e4a100b95bf5bca301d7b.tar.gz
gentoo-978628396f720043563e4a100b95bf5bca301d7b.tar.bz2
gentoo-978628396f720043563e4a100b95bf5bca301d7b.zip
app-emacs/forge: bump to 0.4.6
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/forge/Manifest1
-rw-r--r--app-emacs/forge/forge-0.4.6.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-emacs/forge/Manifest b/app-emacs/forge/Manifest
index 0f9fb4cbe54b..76dee3c6b681 100644
--- a/app-emacs/forge/Manifest
+++ b/app-emacs/forge/Manifest
@@ -1 +1,2 @@
DIST forge-0.4.5.tar.gz 129600 BLAKE2B 55a0e48d79a0dc17e8a1b923a324a9210e25cd6fda11294d09b3659a47dc3fe324134c0e2d2a274db97fd86aefd58068739f5c1d1da1e6b68cbc57b371c70347 SHA512 e4b4269c1b4f9630861c988a12eb4c86b76cdaf57d0d80d2acd697f30315daa586caef39c53fb3b9490f05fea70d04476a99804b131c7028a7cc0b769758f594
+DIST forge-0.4.6.tar.gz 129829 BLAKE2B 33262a395f27a00b240573b2b4a909b1044c7e9f6ca6d506d3652f88c5b43667bdb3e09d3a122492c98388a14568e7c2dd73625fbf112b9ffda86443a6994579 SHA512 06693c05b21bc09f0f72f6d44a7c23350b0a7c277b0eeb588db40bfcb6b387ebf81f1d76b1f78f3248576802a2cca9eae0240d3ee691357539b7e395e31d1dce
diff --git a/app-emacs/forge/forge-0.4.6.ebuild b/app-emacs/forge/forge-0.4.6.ebuild
new file mode 100644
index 000000000000..ccc37c078018
--- /dev/null
+++ b/app-emacs/forge/forge-0.4.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="27.1"
+
+inherit elisp
+
+DESCRIPTION="Work with Git forges from the comfort of Magit"
+HOMEPAGE="https://magit.vc/
+ https://github.com/magit/forge/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+S="${WORKDIR}/${P}/lisp"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.1.0
+ >=app-emacs/ghub-4.1.1
+ >=app-emacs/magit-4.1.3
+ >=app-emacs/transient-0.7.6
+ app-emacs/closql
+ app-emacs/dash
+ app-emacs/emacsql
+ app-emacs/markdown-mode
+ app-emacs/yaml
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+DOCS=( ../README.org )
+ELISP_TEXINFO="../docs/*.texi"
+SITEFILE="50${PN}-gentoo.el"