summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-13 18:11:45 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-13 22:57:02 +0200
commitb24cfdfbea7ccd91289c4096e909e43c161c8e5f (patch)
tree2f96d6d874ba737cbcb61fd8d81776978035001b /app-emacs
parentapp-emacs/orderless: bump to 1.2 (diff)
downloadgentoo-b24cfdfbea7ccd91289c4096e909e43c161c8e5f.tar.gz
gentoo-b24cfdfbea7ccd91289c4096e909e43c161c8e5f.tar.bz2
gentoo-b24cfdfbea7ccd91289c4096e909e43c161c8e5f.zip
app-emacs/php-mode: bump to 1.26.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/php-mode/Manifest1
-rw-r--r--app-emacs/php-mode/php-mode-1.26.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-emacs/php-mode/Manifest b/app-emacs/php-mode/Manifest
index 9668562fe164..95dd9828d765 100644
--- a/app-emacs/php-mode/Manifest
+++ b/app-emacs/php-mode/Manifest
@@ -1 +1,2 @@
DIST php-mode-1.25.1.tar.gz 131105 BLAKE2B 9672d3e71ead28cc7db78ca5c148340b1e1e2552804c172ac14003384c72c3eccf56f5c258da8f0b6e218976100a374af8f2f0c68595ee6b4a2a90d965b60644 SHA512 4e1acf92a95b7e836893160ae3a3bd7a510d7fa0af5f7a6eb3cc8141c6a90b803a339b5d49527ace4f6ec06364ca794f4b834b7391617420a3219dc95fbf61cc
+DIST php-mode-1.26.1.tar.gz 132347 BLAKE2B aa860304e8772e7b4f0eda98711acb1fced279fda16fe491477deaf47e79ef4a841686906783633a7eedd2d19e1569bd1fb17b693588f1b950ee8a7e540e9c77 SHA512 85e9049f895fbba17cab4ef868336aa992821b3dd4167a2c9e1c8ef748bd9d3ac6a413a125391374552beb02dd2a3a6263bd739da78691361e0500c4e0ed29c8
diff --git a/app-emacs/php-mode/php-mode-1.26.1.ebuild b/app-emacs/php-mode/php-mode-1.26.1.ebuild
new file mode 100644
index 000000000000..c61824e10dae
--- /dev/null
+++ b/app-emacs/php-mode/php-mode-1.26.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs major mode for editing PHP code"
+HOMEPAGE="https://github.com/emacs-php/php-mode/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/emacs-php/${PN}.git"
+else
+ SRC_URI="https://github.com/emacs-php/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+S="${WORKDIR}/${P}/lisp"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( ../AUTHORS.md ../CHANGELOG.md ../CONTRIBUTING.md ../README{,.ja}.md ../docs )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert "${S}" -L ../tests -l ../tests/php-mode-test.el
+
+src_test() {
+ touch ../tests/project/1/.git || die
+
+ elisp_src_test
+}