summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-23 22:14:25 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-23 23:06:55 +0100
commitba3934491f31bcb73ac6b214fed488b756c3bcd2 (patch)
tree45b8686686ba8d3b41f300bf4134a2933f821799 /app-emacs
parentapp-emacs/osm: bump to 1.3 (diff)
downloadgentoo-ba3934491f31bcb73ac6b214fed488b756c3bcd2.tar.gz
gentoo-ba3934491f31bcb73ac6b214fed488b756c3bcd2.tar.bz2
gentoo-ba3934491f31bcb73ac6b214fed488b756c3bcd2.zip
app-emacs/plz: bump to 0.7.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/plz/Manifest1
-rw-r--r--app-emacs/plz/plz-0.7.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/plz/Manifest b/app-emacs/plz/Manifest
index 24ff474c1515..2a0128d369a4 100644
--- a/app-emacs/plz/Manifest
+++ b/app-emacs/plz/Manifest
@@ -1,3 +1,4 @@
DIST plz-0.6.tar.gz 102322 BLAKE2B 61bda1b01262f74a6aac0c452b0f06fc2559a287e41ff64b809c6512cc960802084af792fd26a2ac7e82918724b5b9840609cabc5fadc1e637a4e0048b89f171 SHA512 8e281e750d3536ec7bac1235925d1aca559d0f0e1778721b284e05c6a0a53d4b85342eb39476d4eeaaf40ce0c99578108655ad1761619c07d8b131458595d185
DIST plz-0.7.1.tar.gz 105720 BLAKE2B a73e8429df78f9e660baa1730f172f0a871f8f0323d932a49aadc27e702572b0d2dbc525fa05069d8fe886eb9cfb2019ac1dc349c3a7417f4461967138456a23 SHA512 8ad5bbf5c0eb8ebad68f79a0d71a39017fc4e243fa60655597b9892b6594962b4c337d85e178fd2c28bee51c1a282a4b38d32726406392b3bff1b044acc8bf80
+DIST plz-0.7.2.tar.gz 105864 BLAKE2B b876f69a61452ca932c70e87d35e4442f1ddae4c74c3e124056ff0adae9923d0a374c047a1c1dade705713a9b2aaa5bbfbb73368fde9564b53ce638f90f08ff0 SHA512 01951bbb0e59d6196338a806b4bab030538c411d185acf5462bc1eb4d3130b1da5d78a436e84163dd8167b3705edb6dcafdeef8d4611973521566d34f2ca5654
DIST plz-0.7.tar.gz 105630 BLAKE2B 882e5141d6e069da3c7b32706e459e5bcc71abb1277be39162310cde413784202d21bae4bbf8b61f2b72c0edf71ef7b4615685246be17905bbabc9626a2035d6 SHA512 f3300843d30e4b219e4c3f9e898f99f1f3987c73195fdd40a9022c0ac7e09ac25f217adf619b61fb36e2a4d0ea494f5546226e2d1dd85514d1b111f769b7f5ef
diff --git a/app-emacs/plz/plz-0.7.2.ebuild b/app-emacs/plz/plz-0.7.2.ebuild
new file mode 100644
index 000000000000..7397ae367c6f
--- /dev/null
+++ b/app-emacs/plz/plz-0.7.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="HTTP library with curl backend for GNU Emacs"
+HOMEPAGE="https://github.com/alphapapa/plz.el/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alphapapa/plz.el.git"
+else
+ SRC_URI="https://github.com/alphapapa/plz.el/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/plz.el-${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+PROPERTIES="test_network" # Tests require network access.
+RESTRICT="test"
+
+RDEPEND="net-misc/curl"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert tests -l tests/test-plz.el
+
+src_install() {
+ elisp_src_install
+
+ doinfo ${PN}.info
+}