summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-25 21:44:12 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-25 23:16:17 +0200
commitc1319b642fdea927f99b90d9bd4447852f91b087 (patch)
treecac8c748fd43c7e78f6705c2d9a4300f44301e6b /app-emacs
parentapp-emacs/package-lint: drop old 0.22 (diff)
downloadgentoo-c1319b642fdea927f99b90d9bd4447852f91b087.tar.gz
gentoo-c1319b642fdea927f99b90d9bd4447852f91b087.tar.bz2
gentoo-c1319b642fdea927f99b90d9bd4447852f91b087.zip
app-emacs/package-lint: bump to 0.24
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/package-lint/Manifest1
-rw-r--r--app-emacs/package-lint/package-lint-0.24.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/app-emacs/package-lint/Manifest b/app-emacs/package-lint/Manifest
index cda70b10fb7a..8a24b72249c3 100644
--- a/app-emacs/package-lint/Manifest
+++ b/app-emacs/package-lint/Manifest
@@ -1 +1,2 @@
DIST package-lint-0.23.tar.gz 322339 BLAKE2B c3c0a866d46863248fdcf914049859e9dccf0f921a71cc44f4c386e50f5bafac58ba3d1e04b6dcbd58c650fa1386574b2bb3e014cde972416ca3af7f1158b1a1 SHA512 b6d52dd8edb730c77afdadcde48e3235ce90c0e435faf28f220108d9f5994c4a07e8e9b08f765628a7591c11f8e96cfe1ea25606a1d081bede0923528fbf47e3
+DIST package-lint-0.24.tar.gz 322270 BLAKE2B 364b3700bc856b4e3c51bfc5702ea76ebdc21e96d4498cd0e9c21269bbb134f53b4bde2cdb2d74ad6ed7fa9719ca8e0117bfa2ec543a56b2366d29d52e52a174 SHA512 d4262378ba482f799f036942a2be0cb1df29ed99774a696511531b7ba7350fcc865c7c655ca31bc3b455fc009f088682965c31d4e9c80c592e2c5a8cae911a40
diff --git a/app-emacs/package-lint/package-lint-0.24.ebuild b/app-emacs/package-lint/package-lint-0.24.ebuild
new file mode 100644
index 000000000000..4e048187bf9f
--- /dev/null
+++ b/app-emacs/package-lint/package-lint-0.24.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=26.1
+
+inherit elisp
+
+DESCRIPTION="Linting library for Emacs Lisp package metadata"
+HOMEPAGE="https://github.com/purcell/package-lint/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/purcell/${PN}.git"
+else
+ SRC_URI="https://github.com/purcell/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/compat
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.22-load-data-directory.patch"
+)
+
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITEETC@|${EPREFIX}${SITEETC}/${PN}|" -i "${PN}.el" || die
+
+ # Skip failing test. Tests are marked as "WORK IN PROGRESS" at the
+ # top of the file.
+ local -a skip_tests=(
+ package-lint-test-accept-new-backported-libraries-with-backport-dep
+ package-lint-test-accept-new-backported-sub-libraries-with-backport-dep
+ package-lint-test-accept-normal-deps
+ package-lint-test-accepts-new-backported-functions-with-backport-dep
+ package-lint-test-accepts-new-functions-with-compat
+ package-lint-test-accepts-new-macros-with-compat
+ package-lint-test-error-new-backported-sub-libraries
+ package-lint-test-warn-unversioned-dep
+ )
+ local skip_test=""
+ for skip_test in "${skip_tests[@]}"; do
+ sed -i "/${skip_test}/a (ert-skip nil)" package-lint-test.el || die
+ done
+}
+
+src_install() {
+ elisp-install "${PN}" ${PN}{,-flymake}.el{,c}
+ elisp-make-site-file "${SITEFILE}"
+
+ insinto "${SITEETC}/${PN}"
+ doins -r data
+
+ einstalldocs
+}