summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-19 02:04:10 +0000
committerSam James <sam@gentoo.org>2023-03-19 02:07:38 +0000
commit2bac2b7b6edcd8b849b20578bc9e70302091f6a3 (patch)
tree93bc84f5a7305cc384ee34e88474c258c029d9d8 /app-emulation/aranym
parentapp-text/sgrep: fix configure w/ clang 16 (diff)
downloadgentoo-2bac2b7b6edcd8b849b20578bc9e70302091f6a3.tar.gz
gentoo-2bac2b7b6edcd8b849b20578bc9e70302091f6a3.tar.bz2
gentoo-2bac2b7b6edcd8b849b20578bc9e70302091f6a3.zip
app-emulation/aranym: fix configure w/ clang 16
Closes: https://bugs.gentoo.org/883583 Closes: https://bugs.gentoo.org/900322 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation/aranym')
-rw-r--r--app-emulation/aranym/aranym-1.1.0-r1.ebuild (renamed from app-emulation/aranym/aranym-1.1.0.ebuild)1
-rw-r--r--app-emulation/aranym/files/aranym-1.1.0-configure-clang16.patch30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/aranym/aranym-1.1.0.ebuild b/app-emulation/aranym/aranym-1.1.0-r1.ebuild
index 5c33cc4b867c..6746e9ba4b47 100644
--- a/app-emulation/aranym/aranym-1.1.0.ebuild
+++ b/app-emulation/aranym/aranym-1.1.0-r1.ebuild
@@ -41,6 +41,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.1.0-libcwrap.patch
"${FILESDIR}"/${PN}-1.1.0-ar.patch
"${FILESDIR}"/${PN}-1.1.0-clang-16-register.patch
+ "${FILESDIR}"/${PN}-1.1.0-configure-clang16.patch
)
ECONF_SOURCE="${S}"
diff --git a/app-emulation/aranym/files/aranym-1.1.0-configure-clang16.patch b/app-emulation/aranym/files/aranym-1.1.0-configure-clang16.patch
new file mode 100644
index 000000000000..66d2c091b860
--- /dev/null
+++ b/app-emulation/aranym/files/aranym-1.1.0-configure-clang16.patch
@@ -0,0 +1,30 @@
+https://github.com/aranym/aranym/pull/102
+
+From ef9ba74fcbf868aeb1b0e0b02e53775a14cda0f7 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 19 Mar 2023 01:56:56 +0000
+Subject: [PATCH] configure.ac: fix -Wimplicit-function-declaration in TUN/TAP
+ test
+
+Clang 16 makes -Wimplicit-function-declaration an error by default.
+
+Unfortunately, this can lead to misconfiguration or miscompilation of software as configure
+tests may then return the wrong result.
+
+For more information, see LWN.net [0] or LLVM's Discourse [1], the Gentoo wiki [2],
+or the (new) c-std-porting mailing list [3].
+
+[0] https://lwn.net/Articles/913505/
+[1] https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213
+[2] https://wiki.gentoo.org/wiki/Modern_C_porting
+[3] hosted at lists.linux.dev.
+--- a/configure.ac
++++ b/configure.ac
+@@ -539,6 +539,7 @@ AC_CACHE_CHECK([whether TUN/TAP is supported],
+ #include <net/if.h>
+ #include <net/if_tun.h>
+ #endif
++ #include <string.h>
+ ], [
+ struct ifreq ifr;
+ memset(&ifr, 0, sizeof(ifr));