summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-03-15 10:53:36 +0000
committerMarek Szuba <marecki@gentoo.org>2021-03-15 12:49:17 +0000
commit619066ad26e1faf69b125a1a0600b53f254886ea (patch)
treefaa884bc7afc51f4365bf33ebbfa4481cad0633a /app-emulation/protontricks
parentapp-emulation/protontricks: remove old (diff)
downloadgentoo-619066ad26e1faf69b125a1a0600b53f254886ea.tar.gz
gentoo-619066ad26e1faf69b125a1a0600b53f254886ea.tar.bz2
gentoo-619066ad26e1faf69b125a1a0600b53f254886ea.zip
app-emulation/protontricks: bump to 1.4.4
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-emulation/protontricks')
-rw-r--r--app-emulation/protontricks/Manifest1
-rw-r--r--app-emulation/protontricks/protontricks-1.4.4.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index 82bf1cec311e..219f70b98674 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1 +1,2 @@
DIST protontricks-1.4.3.tar.gz 43573 BLAKE2B 3a3050ba6e940182d81d98498a5558433ceaa4282f5a23fb93b3cfc299699381493eb2912c5f03bb6a8092be5c50b94bf7181208cda3d4c0f4c90c0f438f7f1b SHA512 7ca8c7c273d92f7c4526caaa8c9db6988c642913c33c6b6188d285d5cfbe30924533a9f024135865cdc1a25bd867ac00bd915b0a61417d17fe0e5ee451417e64
+DIST protontricks-1.4.4.tar.gz 45204 BLAKE2B 3fc66acae79a39e8dc7a5d507e4abcdad24da13a03e10954b667769a801ac42addb55980e3de413e71ad5395e773b065f8f1dca2e694c835a07b8993b4fb5f0e SHA512 4c61da27e97f1b46150f2808c27d1fcf7394f2cc4f272eada54abc4fdd9229443405f7466d3a1ba5603e3c40a025dbbd8fde512334c6007a64687867625abc4c
diff --git a/app-emulation/protontricks/protontricks-1.4.4.ebuild b/app-emulation/protontricks/protontricks-1.4.4.ebuild
new file mode 100644
index 000000000000..8aa78e9acad1
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.4.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+SRC_URI="https://github.com/Matoking/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="app-emulation/winetricks
+ $(python_gen_cond_dep '
+ dev-python/vdf[${PYTHON_USEDEP}]
+ ')
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.3_no-setuptools-scm.patch
+)
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ echo "version = '${PV}'" > "${S}"/src/${PN}/_version.py || die "Failed to generate the version file"
+}
+
+pkg_postinst() {
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}