summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2016-05-30 18:59:18 +0200
committerDavide Pesavento <pesa@gentoo.org>2016-05-30 18:59:49 +0200
commit4033c7947e37441860337aec801f4dc37214a328 (patch)
tree20e05a61d28be716ff4207eae7e234a971391290 /app-emulation/q4wine
parentapp-emulation/q4wine: remove old (diff)
downloadgentoo-4033c7947e37441860337aec801f4dc37214a328.tar.gz
gentoo-4033c7947e37441860337aec801f4dc37214a328.tar.bz2
gentoo-4033c7947e37441860337aec801f4dc37214a328.zip
app-emulation/q4wine: version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'app-emulation/q4wine')
-rw-r--r--app-emulation/q4wine/Manifest1
-rw-r--r--app-emulation/q4wine/metadata.xml7
-rw-r--r--app-emulation/q4wine/q4wine-1.3.ebuild67
3 files changed, 73 insertions, 2 deletions
diff --git a/app-emulation/q4wine/Manifest b/app-emulation/q4wine/Manifest
index 015b01c35e96..cc46ae8df335 100644
--- a/app-emulation/q4wine/Manifest
+++ b/app-emulation/q4wine/Manifest
@@ -1,2 +1,3 @@
DIST q4wine-1.0-r3.tar.bz2 889308 SHA256 9f1319dd0baff3834a3938e0a048c1529cb9ea521158370176b706fce0d4d2ff SHA512 df10a2fbf6874f4c4e02dd9c43031453a46c76f03d83321f2d6e9544d0540dd07da1bc9246767c5c91ce17d67d5d236227294efaed9de09f3d5a18afbd60b224 WHIRLPOOL 51b5b4cfc157da6b99154269ef4ef9f38ff91f861864158b789352505af485d8b523a21c6d4b59544804ed3c15cb1c6c756db3f3203c8e3ba55c8396c3630df3
DIST q4wine-1.2-r2.tar.bz2 690922 SHA256 44bac78060233504d0db945533e5da4a92bf8b4ca4ef87928032d14451e42160 SHA512 c47fc3adc756ea4bc33dc10f6de03e0a0e72258d1b4b238930136653a7938869d221ce08f6fcafcd5f012583b28227cf827505a59ee5322e9ab90c2c819fd7cb WHIRLPOOL 564eb944097528248f340ac59462f63bec22211d554ad26f125d46382a30ee2a8b7c8d00dd8874fabe92ae939f6bcf13665158957e0e8dad26e077018e495c0d
+DIST q4wine-1.3.tar.bz2 2819219 SHA256 bb6c0f936cbbb9158982596fb82c2e7a228f07d81af430245197f64c0702423a SHA512 e38cd8c389ec9eb2915b4efb786ba799d61e6c95ec042a746165a2f50de2fc545be2798afe98223aa8410b76ed77e267c99f0ff8f9366f010d2b145ccd8ed34a WHIRLPOOL 581d460f6d84e2ec7ce272352d4db3ae22f06befefbf34bfef72e8bb77cd18c8d8056bcf53389e4f7c1c9265d42c13a6f84704b9a1c8b34977f7d47076084594
diff --git a/app-emulation/q4wine/metadata.xml b/app-emulation/q4wine/metadata.xml
index fba48c5b1641..a55386c688bd 100644
--- a/app-emulation/q4wine/metadata.xml
+++ b/app-emulation/q4wine/metadata.xml
@@ -11,11 +11,14 @@
</maintainer>
<use>
<flag name="gnome">Use the gksu sudo GUI for managing the devices</flag>
- <flag name="icoutils">Enable icoutils support</flag>
+ <flag name="ico">Enable ico support via <pkg>media-gfx/icoutils</pkg></flag>
+ <flag name="icoutils">Enable <pkg>media-gfx/icoutils</pkg> support</flag>
+ <flag name="iso">Support unprivileged mounting of ISO9660 images via <pkg>sys-fs/fuseiso</pkg></flag>
<flag name="kde">Use the kdesu sudo GUI for managing the devices</flag>
- <flag name="wineappdb">Enable Win AppDB browser subsystem</flag>
+ <flag name="wineappdb">Enable Wine AppDB browser support</flag>
</use>
<upstream>
+ <remote-id type="github">brezerk/q4wine</remote-id>
<remote-id type="sourceforge">q4wine</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-emulation/q4wine/q4wine-1.3.ebuild b/app-emulation/q4wine/q4wine-1.3.ebuild
new file mode 100644
index 000000000000..4b28fa8cbb0b
--- /dev/null
+++ b/app-emulation/q4wine/q4wine-1.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+# Upstream names the package PV-rX. We change that to
+# PV_pX so we can use portage revisions.
+MY_P=${PN}-${PV/_p/-r}
+
+DESCRIPTION="Qt GUI configuration tool for Wine"
+HOMEPAGE="http://q4wine.brezblock.org.ua/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+dbus debug +ico +iso qt5 +wineappdb"
+
+CDEPEND="
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsingleapplication[qt5,X]
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ dbus? ( dev-qt/qtdbus:5 )
+ )
+ !qt5? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsingleapplication[qt4,X]
+ dev-qt/qtsql:4[sqlite]
+ dbus? ( dev-qt/qtdbus:4 )
+ )
+"
+DEPEND="${CDEPEND}
+ qt5? ( dev-qt/linguist-tools:5 )
+"
+RDEPEND="${CDEPEND}
+ app-admin/sudo
+ >=sys-apps/which-2.19
+ ico? ( >=media-gfx/icoutils-0.26.0 )
+ iso? ( sys-fs/fuseiso )
+"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_configure() {
+ local mycmakeargs=(
+ -DQT5=$(usex qt5 ON OFF)
+ -DDEBUG=$(usex debug ON OFF)
+ -DWITH_ICOUTILS=$(usex ico ON OFF)
+ -DWITH_SYSTEM_SINGLEAPP=ON
+ -DWITH_WINEAPPDB=$(usex wineappdb ON OFF)
+ -DUSE_BZIP2=OFF
+ -DUSE_GZIP=OFF
+ -DWITH_DBUS=$(usex dbus ON OFF)
+ )
+ cmake-utils_src_configure
+}