summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-08-29 16:06:24 -0700
committerZac Medico <zmedico@gentoo.org>2020-08-29 16:07:07 -0700
commit19a5a24561527f179435c06426d1811ae6308ef8 (patch)
treefae3ed08ce4afc6bd9f37a79fcc1fc107bb12f38 /app-emulation/skopeo/skopeo-1.1.1.ebuild
parentpackage.mask: mask app-cdr/pburn (diff)
downloadgentoo-19a5a24561527f179435c06426d1811ae6308ef8.tar.gz
gentoo-19a5a24561527f179435c06426d1811ae6308ef8.tar.bz2
gentoo-19a5a24561527f179435c06426d1811ae6308ef8.zip
app-emulation/skopeo: Bump to version 1.1.1
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-emulation/skopeo/skopeo-1.1.1.ebuild')
-rw-r--r--app-emulation/skopeo/skopeo-1.1.1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-emulation/skopeo/skopeo-1.1.1.ebuild b/app-emulation/skopeo/skopeo-1.1.1.ebuild
new file mode 100644
index 000000000000..e0c555f2bb9c
--- /dev/null
+++ b/app-emulation/skopeo/skopeo-1.1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+COMMIT=67abbb3cefbdc876447583d5ea45e76bf441eba7
+inherit go-module bash-completion-r1
+
+DESCRIPTION="Command line utility foroperations on container images and image repositories"
+HOMEPAGE="https://github.com/containers/skopeo"
+SRC_URI="https://github.com/containers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="btrfs"
+
+COMMON_DEPEND=">=app-crypt/gpgme-1.5.5:=
+ >=dev-libs/libassuan-2.4.3:=
+ dev-libs/libgpg-error:=
+ btrfs? ( >=sys-fs/btrfs-progs-4.0.1 )
+ >=sys-fs/lvm2-2.02.145:="
+DEPEND="${COMMON_DEPEND}
+ dev-go/go-md2man"
+RDEPEND="${COMMON_DEPEND}"
+
+RESTRICT="test"
+
+src_compile() {
+ local BUILDTAGS
+ BUILDTAGS="containers_image_ostree_stub $(usex btrfs "" exclude_graphdriver_btrfs)"
+ set -- go build -mod=vendor -ldflags "-X main.gitCommit=${COMMIT}" \
+ -gcflags "${GOGCFLAGS}" -tags "${BUILDTAGS}" \
+ -o skopeo ./cmd/skopeo
+ echo "$@"
+ "$@" || die
+ cd docs || die
+ for f in *.1.md; do
+ go-md2man -in ${f} -out ${f%%.md} || die
+ done
+}
+
+src_install() {
+ dobin skopeo
+ doman docs/*.1
+ dobashcomp completions/bash/skopeo
+ insinto /etc/containers
+ newins default-policy.json policy.json
+ insinto /etc/containers/registries.d
+ doins default.yaml
+ keepdir /var/lib/atomic/sigstore
+ einstalldocs
+}