summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-12-01 18:59:29 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-12-01 22:13:58 -0500
commitffe3363fa68d3549cd449a9fe720a323392d3b48 (patch)
treebbeb31bbd39d338be5490718d48cd7935c2df101 /app-emulation/vkd3d-proton
parentapp-emulation/vkd3d-proton: fix ExcessiveLineLength (diff)
downloadgentoo-ffe3363fa68d3549cd449a9fe720a323392d3b48.tar.gz
gentoo-ffe3363fa68d3549cd449a9fe720a323392d3b48.tar.bz2
gentoo-ffe3363fa68d3549cd449a9fe720a323392d3b48.zip
app-emulation/vkd3d-proton: show similar support warning as dxvk-2.0
Unsure if it's exact same requirements (not as well documented), but 2.7 is definitely not usable with nvidia-drivers:0/470 while 2.6 still works. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/vkd3d-proton')
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-2.7.ebuild8
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild8
2 files changed, 16 insertions, 0 deletions
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-2.7.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-2.7.ebuild
index 8aabe093f400..1ab788816702 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-2.7.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-2.7.ebuild
@@ -167,4 +167,12 @@ pkg_postinst() {
elog
elog "See ${EROOT}/usr/share/doc/${PF}/README.md* for details."
fi
+
+ if [[ ! ${REPLACING_VERSIONS##* } ]] ||
+ ver_test ${REPLACING_VERSIONS##* } -lt 2.7
+ then
+ elog
+ elog ">=${PN}-2.7 requires drivers and Wine to support vulkan-1.3, meaning:"
+ elog ">=wine-*-7.1 (or >=wine-proton-7.0), and >=mesa-22.0 (or >=nvidia-drivers-510)"
+ fi
}
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
index 6c6b0e82479d..55490ce310fc 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
@@ -167,4 +167,12 @@ pkg_postinst() {
elog
elog "See ${EROOT}/usr/share/doc/${PF}/README.md* for details."
fi
+
+ if [[ ! ${REPLACING_VERSIONS##* } ]] ||
+ ver_test ${REPLACING_VERSIONS##* } -lt 2.7
+ then
+ elog
+ elog ">=${PN}-2.7 requires drivers and Wine to support vulkan-1.3, meaning:"
+ elog ">=wine-*-7.1 (or >=wine-proton-7.0), and >=mesa-22.0 (or >=nvidia-drivers-510)"
+ fi
}