summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-14 06:22:41 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-08-14 06:25:47 -0400
commit44d2b75c2b8f8151d6d09e7dd2af4c6818e7b280 (patch)
tree851c7baf9bd1005a1c1824401172aceec5ce6adb /app-emulation/wine-proton
parentapp-emulation/wine-staging: pass -mno-avx with mingw unconditionally (diff)
downloadgentoo-44d2b75c2b8f8151d6d09e7dd2af4c6818e7b280.tar.gz
gentoo-44d2b75c2b8f8151d6d09e7dd2af4c6818e7b280.tar.bz2
gentoo-44d2b75c2b8f8151d6d09e7dd2af4c6818e7b280.zip
app-emulation/wine-proton: pass -mno-avx with mingw unconditionally
Upon further consideration 84924628f0009acbe92b94ac28141c7ee322548e result in rather unexpected behavior even if we consider that USE=custom-cflags is unsupported, and giving a way to skip -mno-avx may not be all that worth it. So revert plus tidy and add this bugref. Closes: https://bugs.gentoo.org/912268 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/wine-proton')
-rw-r--r--app-emulation/wine-proton/wine-proton-7.0.6.ebuild4
-rw-r--r--app-emulation/wine-proton/wine-proton-8.0.3c.ebuild7
-rw-r--r--app-emulation/wine-proton/wine-proton-8.0.9999.ebuild7
3 files changed, 13 insertions, 5 deletions
diff --git a/app-emulation/wine-proton/wine-proton-7.0.6.ebuild b/app-emulation/wine-proton/wine-proton-7.0.6.ebuild
index 95664cb0ff23..2d64d08da94f 100644
--- a/app-emulation/wine-proton/wine-proton-7.0.6.ebuild
+++ b/app-emulation/wine-proton/wine-proton-7.0.6.ebuild
@@ -269,11 +269,13 @@ src_configure() {
: "${CROSSCFLAGS:=$(
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+
# -mavx with mingw-gcc has a history of obscure issues and
# disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
# crashes with -march=skylake >=wine-8.10, similar issues with
# znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
- use custom-cflags || append-cflags -mno-avx
+ append-cflags -mno-avx #912268
+
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-proton/wine-proton-8.0.3c.ebuild b/app-emulation/wine-proton/wine-proton-8.0.3c.ebuild
index c5db812fe92b..28c682e79696 100644
--- a/app-emulation/wine-proton/wine-proton-8.0.3c.ebuild
+++ b/app-emulation/wine-proton/wine-proton-8.0.3c.ebuild
@@ -273,14 +273,17 @@ src_configure() {
: "${CROSSCFLAGS:=$(
# >=wine-7.21 <8.10's configure.ac does not pass -fno-strict when
# it should (can be removed when proton is rebased on >=8.10)
- append-cflags '-fno-strict-aliasing'
+ append-cflags -fno-strict-aliasing
+
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+
# -mavx with mingw-gcc has a history of obscure issues and
# disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
# crashes with -march=skylake >=wine-8.10, similar issues with
# znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
- use custom-cflags || append-cflags -mno-avx
+ append-cflags -mno-avx #912268
+
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'
diff --git a/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild b/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild
index 6c5e37bcd5bb..9c15f5e09995 100644
--- a/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild
+++ b/app-emulation/wine-proton/wine-proton-8.0.9999.ebuild
@@ -277,14 +277,17 @@ src_configure() {
: "${CROSSCFLAGS:=$(
# >=wine-7.21 <8.10's configure.ac does not pass -fno-strict when
# it should (can be removed when proton is rebased on >=8.10)
- append-cflags '-fno-strict-aliasing'
+ append-cflags -fno-strict-aliasing
+
filter-flags '-fstack-protector*' #870136
filter-flags '-mfunction-return=thunk*' #878849
+
# -mavx with mingw-gcc has a history of obscure issues and
# disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
# crashes with -march=skylake >=wine-8.10, similar issues with
# znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
- use custom-cflags || append-cflags -mno-avx
+ append-cflags -mno-avx #912268
+
CC=${CROSSCC} test-flags-CC ${CFLAGS:--O2})}"
: "${CROSSLDFLAGS:=$(
filter-flags '-fuse-ld=*'