summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <michal.privoznik@gmail.com>2024-12-02 11:01:56 +0100
committerSam James <sam@gentoo.org>2024-12-02 14:47:36 +0000
commit0607810268d3f81c32bb3b5c80ac353658f084f6 (patch)
treecf3e9f42f1f4b156c75390b7dd72fc075a742649 /app-emulation
parentwww-apps/sonarr-bin: drop 4.0.11.2697 (diff)
downloadgentoo-0607810268d3f81c32bb3b5c80ac353658f084f6.tar.gz
gentoo-0607810268d3f81c32bb3b5c80ac353658f084f6.tar.bz2
gentoo-0607810268d3f81c32bb3b5c80ac353658f084f6.zip
app-emulation/qemu-guest-agent: Ensure pip is available
While we list python as a dependency, it's not enough because the configure script creates a venv and installs various tools into it using pip. Make sure pip is available by setting PYTHON_REQ_USE="ensurepip". Now, since qemu-guest-agent and qemu are both built from the same sources, I just copied PYTHON_REQ_USE from the latter, verbatim. So it lists more USE flags, but that's possibly okay. NB, this is similar to how app-emulation/qemu evolved: dafdf8f41fe242a8b2b51d2b8982a6e447115a58 added dev-python/pip into BDEPEND, a9ca061a7fa2393c69be5b3de53bac2db1289ef1 allowed dev-lang/python[ensurepip] to be chosen instead, f09045568b3e4ec1aab0e0f7a3c237671c6070b7 moved entry from BDEPEND to PYTHON_REQ_USE. Closes: https://bugs.gentoo.org/943034 Signed-off-by: Michal Privoznik <michal.privoznik@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39561 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu-guest-agent/qemu-guest-agent-8.2.0.ebuild1
1 files changed, 1 insertions, 0 deletions
diff --git a/app-emulation/qemu-guest-agent/qemu-guest-agent-8.2.0.ebuild b/app-emulation/qemu-guest-agent/qemu-guest-agent-8.2.0.ebuild
index 8edae8bf7044..d9988b5cbf5e 100644
--- a/app-emulation/qemu-guest-agent/qemu-guest-agent-8.2.0.ebuild
+++ b/app-emulation/qemu-guest-agent/qemu-guest-agent-8.2.0.ebuild
@@ -4,6 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="ensurepip(-),ncurses,readline"
inherit edo systemd toolchain-funcs python-any-r1 udev