summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-11-28 22:05:43 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-11-28 22:12:58 -0500
commit512a7f87e9073240d75b420bb8d2b9c0d5c313ab (patch)
treeaccf59f769e8b34d2cb6f04fca87fdcf42b8ba0d /app-emulation
parentapp-emulation/ruffle: drop 0_p20240929-r1 (diff)
downloadgentoo-512a7f87e9073240d75b420bb8d2b9c0d5c313ab.tar.gz
gentoo-512a7f87e9073240d75b420bb8d2b9c0d5c313ab.tar.bz2
gentoo-512a7f87e9073240d75b420bb8d2b9c0d5c313ab.zip
app-emulation/ruffle: add 0_p20241129
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/ruffle/Manifest2
-rw-r--r--app-emulation/ruffle/ruffle-0_p20241129.ebuild104
2 files changed, 106 insertions, 0 deletions
diff --git a/app-emulation/ruffle/Manifest b/app-emulation/ruffle/Manifest
index 0cd7d44eb07c..395d29eefc95 100644
--- a/app-emulation/ruffle/Manifest
+++ b/app-emulation/ruffle/Manifest
@@ -1,2 +1,4 @@
DIST ruffle-nightly-2024-10-27-vendor.tar.xz 68393412 BLAKE2B 16a3cb7a16900d21c91e900d0dc8b1036120abd2168fea2482473bb9c2170de4e1d5619fad15dd8b9df44228b93167f1b722311f7f54a5dff1a9c78682fdf04a SHA512 d085af00d4417e961bf7e05b7af1c70f222ac1277c701d67ce99084f85648eba521273269732d74ddc281fb71c8762646cd15c6f1f1a05da788f04ea302696b0
DIST ruffle-nightly-2024-10-27.tar.gz 93507412 BLAKE2B fcbcd5639bffa8fd1157e1f19765e7ea6721073fc9af6579562a5412d1d07086f53de7d099001ab4eb1b4d497077f09dd1a6da6eaf92c71f12cd1c61633d6f78 SHA512 19790a6641c61ef7e2c1ec94039452c06ea95273de2868198a307d21da955d4196ae33e0807c8f8c74e3f996dc8e26bebdd59ad8bdfa40c9fe6a8afcc745e91f
+DIST ruffle-nightly-2024-11-29-vendor.tar.xz 67239116 BLAKE2B d2eaaf7c7528207a1fabc67cd52bab37442e4c09a740842840f3e44a0d79c826f17b1014e30fcbb07b9e6346c48d4a92439c209b7f54ddc1897cb4166546a295 SHA512 fbf8589d2c9b21b1cb6e93963e8350fad77854e351538ac8155f16bbc16f0ecb1680f7ac7066d14e7fffefa5ead217acc8b8a9319ded891abdeffd5890797776
+DIST ruffle-nightly-2024-11-29.tar.gz 94965476 BLAKE2B 9440808ebc0f2db33df06f45eaf6b089b56b6ce604537c522ba57bb2e7e6ada4f334fa4e483547af9b203c4047566d88d88dbca93c6ab2dd8d1a5ced20bc6cdb SHA512 380da319ee84bddc9f12d472516471a18177f748b4072d1853e3aa9d6311226230cf5e38ac4b30041507f836ff620c04aa69e6e45407571d752baf77ac7ea42a
diff --git a/app-emulation/ruffle/ruffle-0_p20241129.ebuild b/app-emulation/ruffle/ruffle-0_p20241129.ebuild
new file mode 100644
index 000000000000..9a293c3f8717
--- /dev/null
+++ b/app-emulation/ruffle/ruffle-0_p20241129.ebuild
@@ -0,0 +1,104 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+RUST_MIN_VER=1.81.0
+inherit cargo desktop optfeature xdg
+
+MY_PV=nightly-${PV:3:4}-${PV:7:2}-${PV:9:2}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Flash Player emulator written in Rust"
+HOMEPAGE="https://ruffle.rs/"
+SRC_URI="
+ https://github.com/ruffle-rs/ruffle/archive/refs/tags/${MY_PV}.tar.gz
+ -> ${MY_P}.tar.gz
+ https://dev.gentoo.org/~ionen/distfiles/${MY_P}-vendor.tar.xz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="|| ( Apache-2.0 MIT )"
+LICENSE+="
+ Apache-2.0 BSD-2 BSD Boost-1.0 CC0-1.0 ISC UbuntuFontLicense-1.0 MIT
+ MPL-2.0 OFL-1.1 openssl Unicode-3.0 Unicode-DFS-2016 ZLIB
+" # crates
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# dlopen: libX* (see winit+x11-dl crates -- TODO: need to recheck
+# if still correct and for the potential to be optional on wayland)
+RDEPEND="
+ media-libs/alsa-lib
+ virtual/libudev:=
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXrender
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ virtual/jre:*
+ virtual/pkgconfig
+"
+
+QA_FLAGS_IGNORED="usr/bin/${PN}.*"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0_p20231216-skip-render-tests.patch
+)
+
+src_configure() {
+ local workspaces=(
+ ruffle_{desktop,scanner}
+ exporter
+ $(usev test tests)
+ )
+
+ cargo_src_configure "${workspaces[@]/#/--package=}"
+}
+
+src_test() {
+ local skip=(
+ # may need more investigation, strangely "pass" (xfail) when
+ # RUSTFLAGS is unset, skip for now (bug #915726)
+ --skip from_avmplus/as3/Types/Int/wraparound
+ )
+
+ cargo_src_test -- "${skip[@]}"
+}
+
+src_install() {
+ dodoc README.md
+
+ newicon web/packages/extension/assets/images/icon180.png ${PN}.png
+ make_desktop_entry ${PN} ${PN^} ${PN} "AudioVideo;Player;Emulator;" \
+ "MimeType=application/x-shockwave-flash;application/vnd.adobe.flash.movie;"
+
+ cd "$(cargo_target_dir)" || die
+ newbin ${PN}_desktop ${PN}
+ newbin exporter ${PN}_exporter
+ dobin ${PN}_scanner
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "${PN} is experimental software that is still under heavy development"
+ elog "and only receiving nightly releases. Plans in Gentoo is to update"
+ elog "roughly every months if no known major regressions (feel free to"
+ elog "report if you feel a newer nightly is needed ahead of time)."
+ elog
+ elog "There is currently no plans to support wasm builds / browser"
+ elog "extensions, this provides the desktop viewer and other tools."
+ fi
+
+ optfeature "h264 video decoding" media-libs/openh264
+ optfeature "the in-application file picker" sys-apps/xdg-desktop-portal
+}