summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-09-24 04:28:16 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-09-24 04:28:16 +0200
commit54c2a8c1297b97707b0024bad8191e8fffa82c4c (patch)
tree772431a7acbf58a86f1d128d64759f876b2ae585 /app-emulation
parentapp-emulation/wine-staging: add 7.18 (diff)
downloadgentoo-54c2a8c1297b97707b0024bad8191e8fffa82c4c.tar.gz
gentoo-54c2a8c1297b97707b0024bad8191e8fffa82c4c.tar.bz2
gentoo-54c2a8c1297b97707b0024bad8191e8fffa82c4c.zip
app-emulation/distrobox: new package; add version 1.4.1 and live
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/distrobox/Manifest1
-rw-r--r--app-emulation/distrobox/distrobox-1.4.1.ebuild32
-rw-r--r--app-emulation/distrobox/distrobox-9999.ebuild32
-rw-r--r--app-emulation/distrobox/metadata.xml22
4 files changed, 87 insertions, 0 deletions
diff --git a/app-emulation/distrobox/Manifest b/app-emulation/distrobox/Manifest
new file mode 100644
index 000000000000..becca553ed65
--- /dev/null
+++ b/app-emulation/distrobox/Manifest
@@ -0,0 +1 @@
+DIST distrobox-1.4.1.tar.gz 231405 BLAKE2B 920fc2ccf20ad2b6af2a3ea3dfe5c209cd779d6490e6fb95110af5e74ce56354aa264f413c070a6814253a5c51e82be110b8fc86e536a4ae0881fa22afc16630 SHA512 6cee6b734bf22e678529b93f15cdf98f09506642ef5e204ae73590c29a85e205a16715588c9e49b1c39b71023ea906565078e9c2c1f6368df885d20bf37136e2
diff --git a/app-emulation/distrobox/distrobox-1.4.1.ebuild b/app-emulation/distrobox/distrobox-1.4.1.ebuild
new file mode 100644
index 000000000000..f3fc5a365796
--- /dev/null
+++ b/app-emulation/distrobox/distrobox-1.4.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use any Linux distribution inside your terminal (powered by docker/podman)"
+HOMEPAGE="https://distrobox.privatedns.org/
+ https://github.com/89luca89/distrobox/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/89luca89/${PN}.git"
+else
+ SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3" # GPL-3.0-only !
+SLOT="0"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+src_install() {
+ sh ./install --prefix "${ED}"/usr || die "${PN} install script failed"
+ dodoc *.md
+}
diff --git a/app-emulation/distrobox/distrobox-9999.ebuild b/app-emulation/distrobox/distrobox-9999.ebuild
new file mode 100644
index 000000000000..f3fc5a365796
--- /dev/null
+++ b/app-emulation/distrobox/distrobox-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use any Linux distribution inside your terminal (powered by docker/podman)"
+HOMEPAGE="https://distrobox.privatedns.org/
+ https://github.com/89luca89/distrobox/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/89luca89/${PN}.git"
+else
+ SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3" # GPL-3.0-only !
+SLOT="0"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+src_install() {
+ sh ./install --prefix "${ED}"/usr || die "${PN} install script failed"
+ dodoc *.md
+}
diff --git a/app-emulation/distrobox/metadata.xml b/app-emulation/distrobox/metadata.xml
new file mode 100644
index 000000000000..b88c63cda978
--- /dev/null
+++ b/app-emulation/distrobox/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Use any Linux distribution inside your terminal. Enable both backward and
+ forward compatibility with software and freedom to use whatever
+ distribution you’re more comfortable with. Distrobox uses podman or docker
+ to create containers using the Linux distribution of your choice. The
+ created container will be tightly integrated with the host, allowing
+ sharing of the HOME directory of the user, external storage, external USB
+ devices and graphical apps (X11/Wayland), and audio.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/89luca89/distrobox/issues/</bugs-to>
+ <remote-id type="github">89luca89/distrobox</remote-id>
+ </upstream>
+</pkgmetadata>