summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-07-07 21:50:48 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-07-07 21:57:36 +0200
commitf78a0f7b8d919b864221f7e4d62ff8f4c32b795a (patch)
tree3b4d020b68ce0735ff53735b99a0e18ce88112d4 /app-emulation
parentnet-irc/weechat: Stabilize 4.2.3 amd64, #935715 (diff)
downloadgentoo-f78a0f7b8d919b864221f7e4d62ff8f4c32b795a.tar.gz
gentoo-f78a0f7b8d919b864221f7e4d62ff8f4c32b795a.tar.bz2
gentoo-f78a0f7b8d919b864221f7e4d62ff8f4c32b795a.zip
app-emulation/qtrvsim: ensure Qt6 build
Thanks to asturm for assistance with this. Closes: https://bugs.gentoo.org/933594 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qtrvsim/qtrvsim-0.9.7-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emulation/qtrvsim/qtrvsim-0.9.7-r1.ebuild b/app-emulation/qtrvsim/qtrvsim-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..a50f1b567a64
--- /dev/null
+++ b/app-emulation/qtrvsim/qtrvsim-0.9.7-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="RISC-V CPU simulator for education"
+HOMEPAGE="https://github.com/cvut/qtrvsim"
+SRC_URI="https://github.com/cvut/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-qt/qtbase:6[gui,widgets]
+ virtual/libelf:=
+"
+RDEPEND="${DEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # Fails in 0.9.7, but not in master.
+ cli_stalls
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ # ensure Qt6 build
+ sed "/^ *find_package.*QT NAMES/s/Qt5 //" \
+ -i CMakeLists.txt || die
+}