summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-eselect/eselect-miniaudicle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-eselect/eselect-miniaudicle')
-rw-r--r--app-eselect/eselect-miniaudicle/Manifest1
-rw-r--r--app-eselect/eselect-miniaudicle/eselect-miniaudicle-1.0.1-r1.ebuild28
-rw-r--r--app-eselect/eselect-miniaudicle/files/miniaudicle-1.0.1_list.patch12
-rw-r--r--app-eselect/eselect-miniaudicle/metadata.xml8
4 files changed, 49 insertions, 0 deletions
diff --git a/app-eselect/eselect-miniaudicle/Manifest b/app-eselect/eselect-miniaudicle/Manifest
new file mode 100644
index 000000000000..2d8b49eb6ed8
--- /dev/null
+++ b/app-eselect/eselect-miniaudicle/Manifest
@@ -0,0 +1 @@
+DIST miniaudicle.eselect-1.0.1.bz2 1284 SHA256 c5ff356568e0903385b938192bd59dc2d32867419431ef2336ff48e19415a64b SHA512 259a9e566fcdaae04ed845c1fc797faba422dd562da3721d6d07c1b6ea6de856f7e9fe4dfe5c6895b464231c3e9dfa7fa8718a49085fc3e8f79b9e4c4c340085 WHIRLPOOL 4c3d5567024d7eb9a7901b61864c91d2b96834d420e3857e170050c040caaf204cef6a138de47461e75cd2ed523436f85a4da3ea01c8d10a7b5602701d962680
diff --git a/app-eselect/eselect-miniaudicle/eselect-miniaudicle-1.0.1-r1.ebuild b/app-eselect/eselect-miniaudicle/eselect-miniaudicle-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..3b812fac709d
--- /dev/null
+++ b/app-eselect/eselect-miniaudicle/eselect-miniaudicle-1.0.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils
+
+DESCRIPTION="Manages the /usr/bin/miniAudicle symlink"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/miniaudicle.eselect-${PV}.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-1.2.3"
+
+src_prepare() {
+ # Fixes listing as described in bug 320189, not upstream yet
+ epatch "${FILESDIR}"/miniaudicle-1.0.1_list.patch
+}
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ newins "${WORKDIR}/miniaudicle.eselect-${PV}" miniaudicle.eselect || die
+}
diff --git a/app-eselect/eselect-miniaudicle/files/miniaudicle-1.0.1_list.patch b/app-eselect/eselect-miniaudicle/files/miniaudicle-1.0.1_list.patch
new file mode 100644
index 000000000000..cb29780abfbc
--- /dev/null
+++ b/app-eselect/eselect-miniaudicle/files/miniaudicle-1.0.1_list.patch
@@ -0,0 +1,12 @@
+--- miniaudicle.eselect-1.0.1.orig 2010-07-14 23:21:11.000000000 -0400
++++ miniaudicle.eselect-1.0.1 2010-07-14 23:22:22.000000000 -0400
+@@ -73,7 +73,7 @@
+ targets=( $(find_targets ) )
+ write_list_start "Available miniAudicle audio engines:"
+ for (( i = 0 ; i < ${#targets[@]} ; i = i + 1 )) ; do
+- [[ ${targets[${i}]} == $(basename $(canonicalise ${ROOT}/usr/bin/miniAudicle ) ) ]] && \
++ [[ ${targets[${i}]} == $(basename $(canonicalise ${ROOT}/usr/bin/miniAudicle- ) ) ]] && \
+ targets[${i}]=$(highlight_maker "${targets[${i}]}")
+ done
+ write_numbered_list -m "(none found)" "${targets[@]}"
+
diff --git a/app-eselect/eselect-miniaudicle/metadata.xml b/app-eselect/eselect-miniaudicle/metadata.xml
new file mode 100644
index 000000000000..e96e35b1a37c
--- /dev/null
+++ b/app-eselect/eselect-miniaudicle/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
+