summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-06-12 18:32:44 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-22 20:49:22 +0200
commit745f6e281746015d1ce000c370515de517d2f969 (patch)
tree083be22280d86e50d995239262cf5432a7768b30 /app-forensics/unhide/unhide-20220611.ebuild
parentapp-emulation/faudio: add 24.06 (diff)
downloadgentoo-745f6e281746015d1ce000c370515de517d2f969.tar.gz
gentoo-745f6e281746015d1ce000c370515de517d2f969.tar.bz2
gentoo-745f6e281746015d1ce000c370515de517d2f969.zip
app-forensics/unhide: add 20220611
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/37134 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-forensics/unhide/unhide-20220611.ebuild')
-rw-r--r--app-forensics/unhide/unhide-20220611.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-forensics/unhide/unhide-20220611.ebuild b/app-forensics/unhide/unhide-20220611.ebuild
new file mode 100644
index 000000000000..50157b6d2d57
--- /dev/null
+++ b/app-forensics/unhide/unhide-20220611.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo toolchain-funcs
+
+DESCRIPTION="Forensic tool to find hidden processes and TCP/UDP ports by rootkits/LKMs"
+HOMEPAGE="https://www.unhide-forensics.info"
+SRC_URI="https://github.com/YJesus/Unhide/archive/refs/tags/v${PV}.tar.gz -> ${P}.tgz"
+S="${WORKDIR}/Unhide-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ edo $(tc-getCC) ${CFLAGS} ${LDFLAGS} --static -pthread \
+ unhide-linux*.c unhide-output.c -o unhide
+ edo $(tc-getCC) ${CFLAGS} ${LDFLAGS} --static \
+ unhide-tcp.c unhide-tcp-fast.c unhide-output.c -o unhide-tcp
+}
+
+src_install() {
+ dobin ${PN}
+ dobin ${PN}-tcp
+ dodoc changelog README.txt TODO LEEME.txt LISEZ-MOI.TXT NEWS TODO
+ doman man/unhide.8 man/unhide-tcp.8
+ has "fr" ${LINGUAS} && newman man/fr/unhide.8 unhide.fr.8
+ has "es" ${LINGUAS} && newman man/es/unhide.8 unhide.es.8
+}