summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-04-27 00:00:44 +0200
committerSam James <sam@gentoo.org>2022-05-16 05:23:03 +0000
commite8fd549792770092ca3821aecad76f330e86d00c (patch)
tree6707280934965d994e389a15fa68aeb3388a70c9 /app-forensics
parentapp-forensics/yara: fix tests (diff)
downloadgentoo-e8fd549792770092ca3821aecad76f330e86d00c.tar.gz
gentoo-e8fd549792770092ca3821aecad76f330e86d00c.tar.bz2
gentoo-e8fd549792770092ca3821aecad76f330e86d00c.zip
app-forensics/yara: version bump 4.2.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/yara/Manifest1
-rw-r--r--app-forensics/yara/files/yara-4.2-test.patch (renamed from app-forensics/yara/files/yara-4.2.0-test.patch)0
-rw-r--r--app-forensics/yara/yara-4.2.0-r1.ebuild2
-rw-r--r--app-forensics/yara/yara-4.2.1.ebuild57
4 files changed, 59 insertions, 1 deletions
diff --git a/app-forensics/yara/Manifest b/app-forensics/yara/Manifest
index 4ccdfbf5fb21..9f554729d3ff 100644
--- a/app-forensics/yara/Manifest
+++ b/app-forensics/yara/Manifest
@@ -1 +1,2 @@
DIST yara-4.2.0.tar.gz 1284059 BLAKE2B 735d161fde5f84199315f1ce6d31f1ad79488312bede85d2941a03cb97fe75c3c4db0b3cba75782d338a462d87e9d9ed57b393bbdb68decfb350a1bbd096258b SHA512 24ca707015c77d87126bcaac0991997f6b09403024765d615a06db47191a3f0177e1c1eb4a917ec8412876b61d28f4a708f36999ddd9214c3967968c71ae3b7c
+DIST yara-4.2.1.tar.gz 1285173 BLAKE2B dc290bf7fe85d468fd519e68a12d88097d817ca064a665397ba64768078a2d572b46e488eb48747ea1904207598b41a72a510b4b8e4e8601cf518cb6ab98c322 SHA512 036a35d713647b23998135da0d27c13a8876aa44e18e3c9dc99fa425273d7c4a953cbdc78f413f29e8bf818d84b340d0719e241d2a83b7165a16d97e952c45b0
diff --git a/app-forensics/yara/files/yara-4.2.0-test.patch b/app-forensics/yara/files/yara-4.2-test.patch
index 7072ad7478ac..7072ad7478ac 100644
--- a/app-forensics/yara/files/yara-4.2.0-test.patch
+++ b/app-forensics/yara/files/yara-4.2-test.patch
diff --git a/app-forensics/yara/yara-4.2.0-r1.ebuild b/app-forensics/yara/yara-4.2.0-r1.ebuild
index d0e0619bf1e1..43df5bb723e0 100644
--- a/app-forensics/yara/yara-4.2.0-r1.ebuild
+++ b/app-forensics/yara/yara-4.2.0-r1.ebuild
@@ -26,7 +26,7 @@ DEPEND="
RDEPEND="${DEPEND}"
PDEPEND="python? ( =dev-python/yara-python-$(ver_cut 1)* )"
-PATCHES=( "${FILESDIR}/${P}-test.patch" )
+PATCHES=( "${FILESDIR}/${PN}-$(ver_cut 1-2)-test.patch" )
src_prepare() {
default
diff --git a/app-forensics/yara/yara-4.2.1.ebuild b/app-forensics/yara/yara-4.2.1.ebuild
new file mode 100644
index 000000000000..43df5bb723e0
--- /dev/null
+++ b/app-forensics/yara/yara-4.2.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A malware identification and classification tool"
+HOMEPAGE="http://virustotal.github.io/yara/"
+SRC_URI="https://github.com/virustotal/yara/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${PV/_/-}"
+
+LICENSE="Apache-2.0"
+SLOT="0/8"
+if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE="+dex +dotnet +cuckoo +macho +magic profiling python test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/openssl:=
+ cuckoo? ( dev-libs/jansson:= )
+ magic? ( sys-apps/file:= )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="python? ( =dev-python/yara-python-$(ver_cut 1)* )"
+
+PATCHES=( "${FILESDIR}/${PN}-$(ver_cut 1-2)-test.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable profiling) \
+ $(use_enable cuckoo) \
+ $(use_enable magic) \
+ $(use_enable dotnet) \
+ $(use_enable macho) \
+ $(use_enable dex) \
+ $(use_enable test static)
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ # TODO: Allow tests to work against dyn. lib rather than building
+ # statically just for tests.
+ find "${ED}" -name '*.a' -delete || die
+}