summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/bidiv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/bidiv')
-rw-r--r--app-i18n/bidiv/Manifest3
-rw-r--r--app-i18n/bidiv/bidiv-1.5-r1.ebuild36
-rw-r--r--app-i18n/bidiv/bidiv-1.5_p4.ebuild48
-rw-r--r--app-i18n/bidiv/files/bidiv-1.5-fribidi.patch46
-rw-r--r--app-i18n/bidiv/metadata.xml5
5 files changed, 138 insertions, 0 deletions
diff --git a/app-i18n/bidiv/Manifest b/app-i18n/bidiv/Manifest
new file mode 100644
index 000000000000..6fc5ca48f486
--- /dev/null
+++ b/app-i18n/bidiv/Manifest
@@ -0,0 +1,3 @@
+DIST bidiv-1.5.tgz 13865 SHA256 9b9d869fc7e5a16b5270fd50e85241c93b0438a73223fd340eacae0ea3a8e516 SHA512 f8ddaa4a7ae6e7b723eb6e4f5dc91bd2e189c02e116ecd1fb02d300f12e913e9dbf328d65f40ef8c2e7d8e822d1a612966fe0f59f44129fd5dc7ece26c021cc2 WHIRLPOOL a584f1e46097fe09043d9d4a85e1216174c698521af8d98b2da555da88b72a4e74e7ac76dfa4bae42b2de9f010e911cd93199dea0dd8127d9b024a2d6c5ffdae
+DIST bidiv_1.5-4.debian.tar.gz 5863 SHA256 f777effe7d1882f7080ee80b6bff2e8b224d495502e46a5b32cae94c96421aa3 SHA512 63e998cae38e08181cf4e40a54119b9b4b5ab3ede7fcfbf852a1a7ad51a671d14d4094b3af8b89574eef51f8c6ee34f2eab6242bf69e77d954826931a801e8b1 WHIRLPOOL a2d29191bb6162f0d4a21c8853f1c86d26618430d501c8d2722b6dc6bd97f7d9a4ad152fbd5f1d744245531a2bcd5ee80ea19a07dec51a310bfa117c2c48c4ae
+DIST bidiv_1.5.orig.tar.gz 13865 SHA256 9b9d869fc7e5a16b5270fd50e85241c93b0438a73223fd340eacae0ea3a8e516 SHA512 f8ddaa4a7ae6e7b723eb6e4f5dc91bd2e189c02e116ecd1fb02d300f12e913e9dbf328d65f40ef8c2e7d8e822d1a612966fe0f59f44129fd5dc7ece26c021cc2 WHIRLPOOL a584f1e46097fe09043d9d4a85e1216174c698521af8d98b2da555da88b72a4e74e7ac76dfa4bae42b2de9f010e911cd93199dea0dd8127d9b024a2d6c5ffdae
diff --git a/app-i18n/bidiv/bidiv-1.5-r1.ebuild b/app-i18n/bidiv/bidiv-1.5-r1.ebuild
new file mode 100644
index 000000000000..bb9c13f76923
--- /dev/null
+++ b/app-i18n/bidiv/bidiv-1.5-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A BiDirectional Text Viewer"
+HOMEPAGE="http://www.ivrix.org.il"
+SRC_URI="http://ftp.ivrix.org.il/pub/ivrix/src/cmdline/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/fribidi-0.19.2-r2"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fribidi.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dobin bidiv
+ dodoc README WHATSNEW
+ doman bidiv.1
+}
diff --git a/app-i18n/bidiv/bidiv-1.5_p4.ebuild b/app-i18n/bidiv/bidiv-1.5_p4.ebuild
new file mode 100644
index 000000000000..15e58d96dabb
--- /dev/null
+++ b/app-i18n/bidiv/bidiv-1.5_p4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+PATCH_LEVEL=4
+
+DESCRIPTION="A commandline tool displaying logical Hebrew/Arabic"
+HOMEPAGE="http://packages.qa.debian.org/b/bidiv.html"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}.orig.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}-${PATCH_LEVEL}.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/fribidi-0.19.2-r2"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ # Use order from "series" file:
+ local ddir=${WORKDIR}/debian/patches
+ epatch \
+ "${ddir}"/try_utf8_fix \
+ "${ddir}"/makefile \
+ "${ddir}"/fribidi_019 \
+ "${ddir}"/hyphen_minus \
+ "${ddir}"/term_size_get \
+ "${ddir}"/type_fix \
+ "${ddir}"/cast_fix
+}
+
+src_compile() {
+ tc-export CC
+ emake CC_OPT_FLAGS="-Wall"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc README WHATSNEW "${WORKDIR}"/debian/changelog
+}
diff --git a/app-i18n/bidiv/files/bidiv-1.5-fribidi.patch b/app-i18n/bidiv/files/bidiv-1.5-fribidi.patch
new file mode 100644
index 000000000000..0223329cbe5e
--- /dev/null
+++ b/app-i18n/bidiv/files/bidiv-1.5-fribidi.patch
@@ -0,0 +1,46 @@
+--- bidiv.c
++++ bidiv.c
+@@ -172,7 +172,7 @@
+ }
+ #ifndef TRY_UTF8
+ in[len]='\0';
+- fribidi_iso8859_8_to_unicode(in, unicode_in);
++ fribidi_charset_to_unicode(FRIBIDI_CHAR_SET_ISO8859_8, in, unicode_in);
+ #endif
+
+ /* output the line */
+@@ -201,10 +201,10 @@
+ rtl_line=0;
+
+ if(out_utf8)
+- fribidi_unicode_to_utf8(unicode_out, len,
++ fribidi_unicode_to_charset(FRIBIDI_CHAR_SET_UTF8, unicode_out, len,
+ out);
+ else
+- fribidi_unicode_to_iso8859_8(unicode_out, len,
++ fribidi_unicode_to_charset(FRIBIDI_CHAR_SET_ISO8859_8, unicode_out, len,
+ out);
+ /* if rtl_line (i.e., base_dir is RL), and we didn't fill the
+ entire width, we need to pad with spaces. Maybe in the
+--- Makefile
++++ Makefile
+@@ -1,16 +1,14 @@
+ PREFIX=/usr/local
+ BIN_DIR=$(PREFIX)/bin
+ MAN_PATH=$(PREFIX)/man
+-CC_OPT_FLAGS=-O2 -Wall
+
+-
+-CFLAGS= $(CC_OPT_FLAGS) $(DEFS) `fribidi-config --cflags`
+-LDFLAGS=`fribidi-config --libs`
++CFLAGS+=`pkg-config fribidi --cflags` -Wall
++LIBS=`pkg-config fribidi --libs`
+
+ all: bidiv
+
+ bidiv: bidiv.o
+- $(CC) -o bidiv bidiv.o $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o bidiv bidiv.o $(LIBS)
+
+ clean:
+ rm -f bidiv.o *~
diff --git a/app-i18n/bidiv/metadata.xml b/app-i18n/bidiv/metadata.xml
new file mode 100644
index 000000000000..2d5852c16c60
--- /dev/null
+++ b/app-i18n/bidiv/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cjk</herd>
+</pkgmetadata>