summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-11-13 01:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2020-11-16 14:51:15 -0500
commitd7251582d113573ccf4bb97006acc8ac14009f95 (patch)
tree493ae605db5a2a245c29af8b22dceed7f1bd9a68 /app-i18n/fcitx-qt5/fcitx-qt5-1.2.5.ebuild
parentapp-i18n/fcitx-qt5: Version bump (1.2.4). (diff)
downloadgentoo-d7251582d113573ccf4bb97006acc8ac14009f95.tar.gz
gentoo-d7251582d113573ccf4bb97006acc8ac14009f95.tar.bz2
gentoo-d7251582d113573ccf4bb97006acc8ac14009f95.zip
app-i18n/fcitx-qt5: Version bump (1.2.5).
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'app-i18n/fcitx-qt5/fcitx-qt5-1.2.5.ebuild')
-rw-r--r--app-i18n/fcitx-qt5/fcitx-qt5-1.2.5.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-i18n/fcitx-qt5/fcitx-qt5-1.2.5.ebuild b/app-i18n/fcitx-qt5/fcitx-qt5-1.2.5.ebuild
new file mode 100644
index 000000000000..610eb112d602
--- /dev/null
+++ b/app-i18n/fcitx-qt5/fcitx-qt5-1.2.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2014-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit cmake
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/fcitx/fcitx-qt5"
+fi
+
+DESCRIPTION="Fcitx input method module for Qt 5"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-qt5"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="BSD GPL-2+ GPL-3+ LGPL-2+"
+SLOT="4"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+BDEPEND=">=app-i18n/fcitx-4.2.9:4
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtwidgets:5
+ kde-frameworks/extra-cmake-modules:5
+ virtual/pkgconfig"
+# Private headers of dev-qt/qtgui:5 used.
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ virtual/libintl
+ x11-libs/libxkbcommon"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5"
+
+DOCS=()