summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-i18n/ibus-chewing
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-i18n/ibus-chewing')
-rw-r--r--app-i18n/ibus-chewing/Manifest1
-rw-r--r--app-i18n/ibus-chewing/ibus-chewing-1.4.7.ebuild43
-rw-r--r--app-i18n/ibus-chewing/metadata.xml9
3 files changed, 53 insertions, 0 deletions
diff --git a/app-i18n/ibus-chewing/Manifest b/app-i18n/ibus-chewing/Manifest
new file mode 100644
index 000000000000..04951f440749
--- /dev/null
+++ b/app-i18n/ibus-chewing/Manifest
@@ -0,0 +1 @@
+DIST ibus-chewing-1.4.7-Source.tar.gz 108078 SHA256 73426b024be52eea0182f6b8c7936482ca2df7754e971e0b7980e504afdf8af2 SHA512 70e9c4950ac846c2f0087200d3b42f845ef8f911962d3f6bf37a3a0054606fa0fc061daa5dac390d022dbd29801fbcae596d2c5126270eb6e9843a9e0af4486e WHIRLPOOL 67b12375adfcc40c9e61e8f69e1bddc8b7c2354e9bdbe4a8fde97c6db3f212ca5b426428e1bf96ede1d5c55f5ffe230a57acd026ef1c0b960ee4cdc692aa35ca
diff --git a/app-i18n/ibus-chewing/ibus-chewing-1.4.7.ebuild b/app-i18n/ibus-chewing/ibus-chewing-1.4.7.ebuild
new file mode 100644
index 000000000000..2afcc7fa0686
--- /dev/null
+++ b/app-i18n/ibus-chewing/ibus-chewing-1.4.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit cmake-utils
+
+MY_P=${P}-Source
+
+DESCRIPTION="The Chewing IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="x11-libs/libXtst
+ >=app-i18n/ibus-1.3
+ >=dev-libs/libchewing-0.3.3
+ x11-libs/gtk+:2
+ dev-util/gob:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+CMAKE_IN_SOURCE_BUILD=1
+
+DOCS="AUTHORS ChangeLog README RELEASE-NOTES.txt USER-GUIDE"
+
+src_configure() {
+ local mycmakeargs=(
+ -DPRJ_DOC_DIR=/usr/share/doc/${PF}
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_make all translations
+}
diff --git a/app-i18n/ibus-chewing/metadata.xml b/app-i18n/ibus-chewing/metadata.xml
new file mode 100644
index 000000000000..7d84776d4dff
--- /dev/null
+++ b/app-i18n/ibus-chewing/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <longdescription lang="en">The Chewing engine for IBus platform. It provides Chinese input method from libchewing.</longdescription>
+ <upstream>
+ <remote-id type="google-code">ibus</remote-id>
+ </upstream>
+</pkgmetadata>