summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2022-01-12 00:00:00 +0000
committerYixun Lan <dlan@gentoo.org>2022-01-29 23:18:35 +0800
commitda6212a99d181d54f22c73fb2a9b8a9a5df2d21b (patch)
tree9bc61710ff44ce94e8c26a7f3f0389acf3349892 /app-i18n/mozc
parentdev-python/protobuf-python: Delete old version (3.16.0). (diff)
downloadgentoo-da6212a99d181d54f22c73fb2a9b8a9a5df2d21b.tar.gz
gentoo-da6212a99d181d54f22c73fb2a9b8a9a5df2d21b.tar.bz2
gentoo-da6212a99d181d54f22c73fb2a9b8a9a5df2d21b.zip
app-i18n/mozc: Fix building with >=dev-libs/protobuf-3.18.0
Closes: https://bugs.gentoo.org/828527 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n/mozc')
-rw-r--r--app-i18n/mozc/files/mozc-2.23.2815.102-protobuf-3.18.patch13
-rw-r--r--app-i18n/mozc/mozc-2.23.2815.102.ebuild (renamed from app-i18n/mozc/mozc-2.23.2815.102-r1.ebuild)7
2 files changed, 17 insertions, 3 deletions
diff --git a/app-i18n/mozc/files/mozc-2.23.2815.102-protobuf-3.18.patch b/app-i18n/mozc/files/mozc-2.23.2815.102-protobuf-3.18.patch
new file mode 100644
index 000000000000..15077bb1752a
--- /dev/null
+++ b/app-i18n/mozc/files/mozc-2.23.2815.102-protobuf-3.18.patch
@@ -0,0 +1,13 @@
+Fix building with Protocol Buffers >=3.18.
+
+--- /src/dictionary/user_dictionary_storage.cc
++++ /src/dictionary/user_dictionary_storage.cc
+@@ -108,7 +108,7 @@
+ // wants to use more than 512MB.
+ mozc::protobuf::io::IstreamInputStream zero_copy_input(&ifs);
+ mozc::protobuf::io::CodedInputStream decoder(&zero_copy_input);
+- decoder.SetTotalBytesLimit(kDefaultTotalBytesLimit, -1);
++ decoder.SetTotalBytesLimit(kDefaultTotalBytesLimit);
+ if (!user_dictionary_storage_base.ParseFromCodedStream(&decoder)) {
+ LOG(ERROR) << "Failed to parse";
+ if (!decoder.ConsumedEntireMessage() || !ifs.eof()) {
diff --git a/app-i18n/mozc/mozc-2.23.2815.102-r1.ebuild b/app-i18n/mozc/mozc-2.23.2815.102.ebuild
index 0d8162f9bcdb..88ce0b3c1c22 100644
--- a/app-i18n/mozc/mozc-2.23.2815.102-r1.ebuild
+++ b/app-i18n/mozc/mozc-2.23.2815.102.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2010-2021 Gentoo Authors
+# Copyright 2010-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -41,13 +41,13 @@ REQUIRED_USE="|| ( emacs fcitx4 ibus ) gui? ( ^^ ( handwriting-tegaki handwritin
RESTRICT="!test? ( test )"
BDEPEND="${PYTHON_DEPS}
- <dev-libs/protobuf-3.19
+ >=dev-libs/protobuf-3.0.0
dev-util/gyp
dev-util/ninja
virtual/pkgconfig
emacs? ( app-editors/emacs:* )
fcitx4? ( sys-devel/gettext )"
-RDEPEND="<dev-libs/protobuf-3.19:=
+RDEPEND=">=dev-libs/protobuf-3.0.0:=
emacs? ( app-editors/emacs:* )
fcitx4? (
app-i18n/fcitx:4
@@ -113,6 +113,7 @@ src_prepare() {
eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-system_libraries.patch"
eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-gcc-8.patch"
eapply -p2 "${DISTDIR}/${PN}-2.23.2815.102-protobuf_generated_classes_no_inheritance.patch"
+ eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-protobuf-3.18.patch"
eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-environmental_variables.patch"
eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-reiwa.patch"
eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-server_path_check.patch"