summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-07-21 20:40:07 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-21 20:41:20 +0300
commit6b9405a31c42e18828fdb05f0d90a2e804d474d9 (patch)
tree2041cba4bbfd5547c59a93100f8e29e97bf30665 /app-i18n
parentapp-i18n/librime: add 1.11.2 (diff)
downloadgentoo-6b9405a31c42e18828fdb05f0d90a2e804d474d9.tar.gz
gentoo-6b9405a31c42e18828fdb05f0d90a2e804d474d9.tar.bz2
gentoo-6b9405a31c42e18828fdb05f0d90a2e804d474d9.zip
app-i18n/librime: refactor after PR
Closes: https://github.com/gentoo/gentoo/pull/37654 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/librime/librime-1.11.2.ebuild25
1 files changed, 11 insertions, 14 deletions
diff --git a/app-i18n/librime/librime-1.11.2.ebuild b/app-i18n/librime/librime-1.11.2.ebuild
index 1c2d933f72f8..30ed5c8e5578 100644
--- a/app-i18n/librime/librime-1.11.2.ebuild
+++ b/app-i18n/librime/librime-1.11.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 2012-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="8"
+EAPI=8
-inherit cmake multiprocessing
+inherit cmake multiprocessing flag-o-matic
DESCRIPTION="RIME (Rime Input Method Engine) core library"
HOMEPAGE="https://rime.im/ https://github.com/rime/librime"
@@ -16,36 +16,33 @@ IUSE="debug test"
RESTRICT="!test? ( test )"
RDEPEND="
+ app-i18n/opencc:=
dev-cpp/glog:=
+ dev-cpp/yaml-cpp:=
>=dev-libs/boost-1.74:=
- app-i18n/opencc:0=
- dev-cpp/yaml-cpp:0=
- dev-libs/leveldb:0=
- dev-libs/marisa:0=
+ dev-libs/leveldb:=
+ dev-libs/marisa
"
DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )
"
-DOCS=(CHANGELOG.md README.md)
+DOCS=( CHANGELOG.md README.md )
src_configure() {
- local -x CXXFLAGS="${CXXFLAGS}"
-
# for glog
if use debug; then
- CXXFLAGS+=" -DDCHECK_ALWAYS_ON"
- CMAKE_BUILD_TYPE=Debug
+ append-cxxflags -DDCHECK_ALWAYS_ON
+ local CMAKE_BUILD_TYPE=Debug
else
- CXXFLAGS+=" -DNDEBUG"
+ append-cxxflags -DNDEBUG
fi
local mycmakeargs=(
- -DBUILD_TEST=$(usex test ON OFF)
+ -DBUILD_TEST=$(usex test)
-DCMAKE_BUILD_PARALLEL_LEVEL=$(makeopts_jobs)
-DENABLE_EXTERNAL_PLUGINS=ON
-DINSTALL_PRIVATE_HEADERS=ON
)
-
cmake_src_configure
}