summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2024-04-14 14:52:38 +0900
committerAkinori Hattori <hattya@gentoo.org>2024-04-14 15:10:41 +0900
commit9bef7cdc537fd5b649d935e7e9af747582605419 (patch)
tree213545d4dc1738a64f22a9cf592994a95ec20fb1 /app-i18n
parentapp-i18n/nkf: drop old (diff)
downloadgentoo-9bef7cdc537fd5b649d935e7e9af747582605419.tar.gz
gentoo-9bef7cdc537fd5b649d935e7e9af747582605419.tar.bz2
gentoo-9bef7cdc537fd5b649d935e7e9af747582605419.zip
app-i18n/nkf: migrate to PEP 517
Closes: https://bugs.gentoo.org/909877 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/nkf/nkf-2.1.5-r1.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/app-i18n/nkf/nkf-2.1.5-r1.ebuild b/app-i18n/nkf/nkf-2.1.5-r1.ebuild
index 44490ab3b00b..c7174e579705 100644
--- a/app-i18n/nkf/nkf-2.1.5-r1.ebuild
+++ b/app-i18n/nkf/nkf-2.1.5-r1.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=8
+EAPI="8"
PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517="setuptools"
DISTUTILS_OPTIONAL="1"
+DISTUTILS_EXT="1"
inherit distutils-r1 perl-module toolchain-funcs vcs-snapshot
@@ -26,7 +28,7 @@ RDEPEND="python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}"
BDEPEND="python? (
${PYTHON_DEPS}
- dev-python/setuptools[${PYTHON_USEDEP}]
+ ${DISTUTILS_DEPS}
)"
src_unpack() {
@@ -40,9 +42,11 @@ src_prepare() {
Makefile
if use python; then
mv "${WORKDIR}"/${PY_P} NKF.python || die
+ sed -i "s/-/_/g" NKF.python/setup.cfg
+
eapply "${FILESDIR}"/${PN}-python.patch
eapply "${FILESDIR}"/${P}-python-ssize_t.patch
- eapply "${FILESDIR}"/${PN}-2.1.5-python-ssize_t-deux.patch
+ eapply "${FILESDIR}"/${P}-python-ssize_t-deux.patch
cd NKF.python || die
distutils-r1_src_prepare