summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2023-05-12 08:07:38 +0800
committerYixun Lan <dlan@gentoo.org>2023-05-12 08:11:06 +0800
commitc2ec315acbc673833f5e076c9e8f3b52b2826537 (patch)
treec636dca9fc7d05ff801269862e64b9ffd99b9f7a /app-i18n
parentnet-misc/autossh: fix undefined setproctile & QA issue (diff)
downloadgentoo-c2ec315acbc673833f5e076c9e8f3b52b2826537.tar.gz
gentoo-c2ec315acbc673833f5e076c9e8f3b52b2826537.tar.bz2
gentoo-c2ec315acbc673833f5e076c9e8f3b52b2826537.zip
app-i18n/ibus-pinyin: fix preference issue in ibus-setup
Closes: https://bugs.gentoo.org/905906 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-pinyin/files/ibus-pinyin-1.5.0-gettext.patch16
-rw-r--r--app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r6.ebuild64
2 files changed, 80 insertions, 0 deletions
diff --git a/app-i18n/ibus-pinyin/files/ibus-pinyin-1.5.0-gettext.patch b/app-i18n/ibus-pinyin/files/ibus-pinyin-1.5.0-gettext.patch
new file mode 100644
index 000000000000..2014bad9820a
--- /dev/null
+++ b/app-i18n/ibus-pinyin/files/ibus-pinyin-1.5.0-gettext.patch
@@ -0,0 +1,16 @@
+--- a/setup/main.py
++++ b/setup/main.py
+@@ -45,7 +45,12 @@ class PreferencesDialog:
+ locale.setlocale(locale.LC_ALL, "")
+ localedir = os.getenv("IBUS_LOCALEDIR")
+ gettext.bindtextdomain("ibus-pinyin", localedir)
+- gettext.bind_textdomain_codeset("ibus-pinyin", "UTF-8")
++ # Python's gettext module doesn't provide all methods in
++ # new Python version since Python 3.10
++ try:
++ gettext.bind_textdomain_codeset("ibus-pinyin", "UTF-8")
++ except AttributeError:
++ pass
+
+ self.__bus = IBus.Bus()
+ self.__config = self.__bus.get_config()
diff --git a/app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r6.ebuild b/app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r6.ebuild
new file mode 100644
index 000000000000..f3dd89c2dced
--- /dev/null
+++ b/app-i18n/ibus-pinyin/ibus-pinyin-1.5.0-r6.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2008-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+LUA_COMPAT=( lua5-1 )
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit autotools lua-single python-single-r1
+
+DESCRIPTION="Chinese Pinyin and Bopomofo engines for IBus"
+HOMEPAGE="https://github.com/ibus/ibus-pinyin"
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/ibus/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="boost lua nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ lua? ( ${LUA_REQUIRED_USE} )"
+
+RDEPEND="${PYTHON_DEPS}
+ app-i18n/pyzy
+ dev-db/sqlite:3
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ boost? ( dev-libs/boost )
+ lua? ( ${LUA_DEPS} )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/autoconf-archive
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-boost.patch
+ "${FILESDIR}"/${P}-content-type-method.patch
+ "${FILESDIR}"/${P}-python3.patch
+ "${FILESDIR}"/${P}-sqlite-3.41.0.patch
+ "${FILESDIR}"/${P}-gettext.patch #905906
+)
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+
+ if use lua; then
+ lua-single_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable boost) \
+ $(use_enable lua lua-extension) \
+ $(use_enable nls)
+}