summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-05-25 02:49:19 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-05-25 02:49:19 +0200
commit5ff6e1a3442f0ccd1340ea4f0c760e8e2aaf5775 (patch)
tree9e6569233a1b0b736cf8e54016ea39690d4016aa /app-metrics/pushgateway/pushgateway-0.5.0.ebuild
parentnet-print/mtink: remove unused patch (diff)
downloadgentoo-5ff6e1a3442f0ccd1340ea4f0c760e8e2aaf5775.tar.gz
gentoo-5ff6e1a3442f0ccd1340ea4f0c760e8e2aaf5775.tar.bz2
gentoo-5ff6e1a3442f0ccd1340ea4f0c760e8e2aaf5775.zip
app-metrics/pushgateway: Version bump to 0.5.0
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'app-metrics/pushgateway/pushgateway-0.5.0.ebuild')
-rw-r--r--app-metrics/pushgateway/pushgateway-0.5.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-metrics/pushgateway/pushgateway-0.5.0.ebuild b/app-metrics/pushgateway/pushgateway-0.5.0.ebuild
new file mode 100644
index 000000000000..80fde6225b68
--- /dev/null
+++ b/app-metrics/pushgateway/pushgateway-0.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot systemd
+
+EGO_PN="github.com/prometheus/pushgateway"
+EGIT_COMMIT="v${PV/_rc/-rc.}"
+GIT_COMMIT="3965d2a"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus push acceptor for ephemeral and batch jobs"
+HOMEPAGE="https://github.com/prometheus/pushgateway"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-util/promu"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${GIT_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ mkdir -p bin || die
+ GOPATH="${S}" promu build -v --prefix bin || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin bin/pushgateway
+ dodoc {README,CHANGELOG,CONTRIBUTING}.md
+ popd || die
+ keepdir /var/lib/${PN} /var/log/${PN}
+ fowners ${PN}:${PN} /var/lib/${PN} /var/log/${PN}
+ newinitd "${FILESDIR}"/${PN}-1.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}-1.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}-1.service"
+}