summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2024-02-03 17:12:26 +0100
committerFabian Groffen <grobian@gentoo.org>2024-02-03 17:12:49 +0100
commit7a6ed359c687da00ae6dc1f58e6cd97ec5ac34f5 (patch)
treef3da8840f0ffae3fc06754d72eb85872fe29bccd /app-metrics
parentgui-libs/libadwaita: drop 1.3.5, 1.4.0 (diff)
downloadgentoo-7a6ed359c687da00ae6dc1f58e6cd97ec5ac34f5.tar.gz
gentoo-7a6ed359c687da00ae6dc1f58e6cd97ec5ac34f5.tar.bz2
gentoo-7a6ed359c687da00ae6dc1f58e6cd97ec5ac34f5.zip
app-metrics/go-carbon-0.17.3: version bump
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/go-carbon/Manifest1
-rw-r--r--app-metrics/go-carbon/go-carbon-0.17.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-metrics/go-carbon/Manifest b/app-metrics/go-carbon/Manifest
index db8bef38af66..57f84fec0200 100644
--- a/app-metrics/go-carbon/Manifest
+++ b/app-metrics/go-carbon/Manifest
@@ -1 +1,2 @@
DIST go-carbon-0.17.1.tar.gz 5074817 BLAKE2B 59b708ee2eeea486e3f4612efbe94e0592f920de3a194f7d89b4c92df88c65027373871a1503f9ce1027bc1695f19d86503de6da4789b7277780a08871f1c893 SHA512 d18e5768fa8942d3ad8039f2c8304797c488d892aae2d3bca64e2659d7bd432e9c8db14dae22eae86be9e6217b0ea567e2f40b4395c7123a7871f75afed82fc0
+DIST go-carbon-0.17.3.tar.gz 5426401 BLAKE2B 8f2ea61524b9fdc70c7d233d4e88c7190351c970cc787d80de14e51d4cc4ad94413774c7ca86fbf4910bffc3ad241b266772969305378afc289a146f7ad69318 SHA512 16e12099692da6a6b8df55816f5b7b91777c384ca292ea309c16513096e8601cb447e7ef4530466e6b989042efc4b31d8190290b35938d2e0e654f4ae6da70bb
diff --git a/app-metrics/go-carbon/go-carbon-0.17.3.ebuild b/app-metrics/go-carbon/go-carbon-0.17.3.ebuild
new file mode 100644
index 000000000000..2402f67a999f
--- /dev/null
+++ b/app-metrics/go-carbon/go-carbon-0.17.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="Golang implementation of Graphite/Carbon server"
+HOMEPAGE="https://github.com/go-graphite/go-carbon"
+SRC_URI="https://github.com/go-graphite/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ acct-group/carbon
+ acct-user/carbon"
+BDEPEND=""
+
+src_prepare() {
+ export BUILD="gentoo-${PVR}"
+
+ # bug 904050: -race conflicts with -buildmode=pie added by go-module
+ sed -i \
+ -e '/make run-test COMMAND="test -race"/d' \
+ -e '/make run-test COMMAND="vet"/d' \
+ Makefile || die
+
+ eapply_user
+}
+
+src_install() {
+ insinto /etc/go-carbon
+ doins "${S}"/go-carbon.conf.example
+ dobin go-carbon
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}