summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2024-02-19 13:31:29 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-04-20 10:53:48 +0300
commit16e69985dbd232a50f5aea46bf2b542330f9edaf (patch)
tree8d952fdc9eaa4687a408458f617b16d23547ea68 /app-misc/boxes
parentdev-ruby/ruby-odbc: add 0.999992 (diff)
downloadgentoo-16e69985dbd232a50f5aea46bf2b542330f9edaf.tar.gz
gentoo-16e69985dbd232a50f5aea46bf2b542330f9edaf.tar.bz2
gentoo-16e69985dbd232a50f5aea46bf2b542330f9edaf.zip
app-misc/boxes: add 2.3.0
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc/boxes')
-rw-r--r--app-misc/boxes/Manifest1
-rw-r--r--app-misc/boxes/boxes-2.3.0.ebuild52
-rw-r--r--app-misc/boxes/files/boxes-2.3.0-ncurses-gentoo.patch15
3 files changed, 68 insertions, 0 deletions
diff --git a/app-misc/boxes/Manifest b/app-misc/boxes/Manifest
index 03128661adba..a545a49b7a36 100644
--- a/app-misc/boxes/Manifest
+++ b/app-misc/boxes/Manifest
@@ -1,2 +1,3 @@
DIST boxes-2.2.0.tar.gz 230099 BLAKE2B 4adb8ddde85cb31f32e98916d5ea2a57afcaa0470f796ba296cb3b80780f158a24b2bc5e9ba923b6a3b35b8f7781cd6ddacd89abadf6f2c07549be7ffe1458f4 SHA512 534d441c34316572d0c7e89f343a3bc5bb5a8466e4d4ed703fb2d14b714f5a6b224f7b0d408525d492da4610f9c5ffd8508e16d98a0781897567fb4aeb316f39
DIST boxes-2.2.1.tar.gz 230900 BLAKE2B 65ab0c8ad52d2764279397135b072bfa6f4bf86e465cc3a4778d30c5b19ce2c0d7c5f8636173529eca92754ee16d38b46a83b067b94315b1ea82448e4b1ac0a8 SHA512 0afa115d5ec01944878ef4d8f33e2887d123b172a0589eda53a04ba671916d9ef1d8299f9df9aeac8989807f86ca1b96b1c34aed03856643a89a07586b82e3b6
+DIST boxes-2.3.0.tar.gz 272302 BLAKE2B 282b41aee214f54aa3c8b237bc9f2e48e4144eebd6619880a38c7a71d9bf7bb434a250f29a05f20746530e8458bb0d062cd7e5bea88ebdf64030f090b1a8674a SHA512 d7580462ed5cf8a3299f528d7e4abea1c9733da2823c204bff69a804c72b768c4d3e8505b4d8881aae066f1fd95133cf9dc52e960333a82d8c529f85eb096fb4
diff --git a/app-misc/boxes/boxes-2.3.0.ebuild b/app-misc/boxes/boxes-2.3.0.ebuild
new file mode 100644
index 000000000000..5315f2592d7e
--- /dev/null
+++ b/app-misc/boxes/boxes-2.3.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Draw any kind of boxes around your text"
+HOMEPAGE="https://boxes.thomasjensen.com/ https://github.com/ascii-boxes/boxes"
+SRC_URI="https://github.com/ascii-boxes/boxes/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/libpcre2:=[pcre32]
+ dev-libs/libunistring:=
+ sys-libs/ncurses:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ app-alternatives/yacc
+ app-alternatives/lex
+ test? ( app-editors/vim-core )
+"
+
+PATCHES=( "${FILESDIR}/${P}-ncurses-gentoo.patch" )
+
+src_prepare() {
+ default
+
+ sed \
+ -e 's:STRIP=true:STRIP=false:g' \
+ -i src/Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS_ADDTL="${CFLAGS}" LDFLAGS_ADDTL="${LDFLAGS}"
+}
+
+src_install() {
+ dobin out/boxes
+ doman doc/boxes.1
+ insinto /usr/share
+ newins boxes-config boxes
+ einstalldocs
+}
diff --git a/app-misc/boxes/files/boxes-2.3.0-ncurses-gentoo.patch b/app-misc/boxes/files/boxes-2.3.0-ncurses-gentoo.patch
new file mode 100644
index 000000000000..38e7117592e4
--- /dev/null
+++ b/app-misc/boxes/files/boxes-2.3.0-ncurses-gentoo.patch
@@ -0,0 +1,15 @@
+Gentoo splits ncurses into several independent libraries. Therefore this needs to be linked with more than just -lncurses.
+
+Pascal Jäger <pascal.jaeger@leimstift.de> (2024-02-19)
+
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -64,7 +64,7 @@ debug: flags_$(BOXES_PLATFORM) | $(OUT_DIR)
+ CFLAGS_ADDTL="-ggdb3 $(CFLAGS_ADDTL)" flags_$(BOXES_PLATFORM) $(BOXES_EXECUTABLE_NAME)
+
+ boxes: $(ALL_OBJ) | check_dir
+- $(CC) $(LDFLAGS) $^ -o $@ -lunistring -lpcre2-32 -lncurses
++ $(CC) $(LDFLAGS) $^ -o $@ -lunistring -lpcre2-32 $(shell pkg-config --libs ncurses)
+ if [ "$(STRIP)" = "true" ] ; then strip $@ ; fi
+
+ boxes.static: $(ALL_OBJ) | check_dir