summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2017-03-06 09:18:04 +0100
committerGöktürk Yüksek <gokturk@gentoo.org>2017-03-16 17:33:13 -0400
commita11697b6b1a1ffdc22f32ff812bd447daacf35e9 (patch)
treee1123faa8a8d20b7232740c811fd7fcbf1f0e268 /app-misc/chkcrontab/chkcrontab-1.7.ebuild
parentsys-kernel/ck-sources: properly call kernel-2_src_prepare in src_prepare (diff)
downloadgentoo-a11697b6b1a1ffdc22f32ff812bd447daacf35e9.tar.gz
gentoo-a11697b6b1a1ffdc22f32ff812bd447daacf35e9.tar.bz2
gentoo-a11697b6b1a1ffdc22f32ff812bd447daacf35e9.zip
app-misc/chkcrontab: bump to 1.7
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-misc/chkcrontab/chkcrontab-1.7.ebuild')
-rw-r--r--app-misc/chkcrontab/chkcrontab-1.7.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-misc/chkcrontab/chkcrontab-1.7.ebuild b/app-misc/chkcrontab/chkcrontab-1.7.ebuild
new file mode 100644
index 000000000000..97df477c808c
--- /dev/null
+++ b/app-misc/chkcrontab/chkcrontab-1.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to detect crontab errors"
+HOMEPAGE="https://github.com/lyda/chkcrontab"
+SRC_URI="https://github.com/lyda/chkcrontab/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+python_test() {
+ esetup.py test || die
+}
+
+python_install_all() {
+ doman doc/${PN}.1
+ distutils-r1_python_install_all
+}