summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/email2trac
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/email2trac')
-rw-r--r--app-misc/email2trac/Manifest2
-rw-r--r--app-misc/email2trac/email2trac-2.6.2-r1.ebuild39
-rw-r--r--app-misc/email2trac/email2trac-2.8.4.ebuild39
-rw-r--r--app-misc/email2trac/metadata.xml10
4 files changed, 90 insertions, 0 deletions
diff --git a/app-misc/email2trac/Manifest b/app-misc/email2trac/Manifest
new file mode 100644
index 000000000000..adbefef859bf
--- /dev/null
+++ b/app-misc/email2trac/Manifest
@@ -0,0 +1,2 @@
+DIST email2trac-2.6.2.tar.gz 104732 SHA256 4d1ccd12e18a303d3700eeb5449eb330ddbc13ed66103df79fffed950fd9243f SHA512 69b596b4c60ccc40b53ddfce5c13d5d7f27ac1fc5674e1cb3fbf84b083c2abc77d36879d665924a62b826e7d3a52d0ead1e1d693a55aae5edfc092998e01a0df WHIRLPOOL ac92802ab7fc0c0b6e0daddd3f723f1b21b2772f63dc9a6194db78572fc039c0d4f3602f1dc55caf5cc9387d481c9bf2aabb7961fb91147060ecce48926e13d5
+DIST email2trac-2.8.4.tar.gz 107791 SHA256 2673ea60f355c812d890346c1eaa9d0a65c791d214bf545b171ed66a8feceafb SHA512 f0bfd00442d50090f9cc582849026b08bb091bc72223b4569597c2ffdb57759206500da65390dc1609a24e521e137aee072d1ee3412391bf0e4b778933ff2165 WHIRLPOOL 18b35e889fc52e488dc88b7ef73302d8497961bf2710e3353b3d21c3514191bfdc4ec7d99ff9ad2c92cb9626d2db2f5dbca92e03963fe4b90e29d35f308118f4
diff --git a/app-misc/email2trac/email2trac-2.6.2-r1.ebuild b/app-misc/email2trac/email2trac-2.6.2-r1.ebuild
new file mode 100644
index 000000000000..21a97b6f79a3
--- /dev/null
+++ b/app-misc/email2trac/email2trac-2.6.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+DESCRIPTION="Utilities to convert emails to trac tickets"
+HOMEPAGE="https://oss.trac.surfsara.nl/email2trac"
+SRC_URI="ftp://ftp.sara.nl/pub/outgoing/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ <www-apps/trac-1.1[${PYTHON_USEDEP}]"
+
+pkg_setup() {
+ einfo "You can set the following variables in make.conf:"
+ einfo " - EMAIL2TRAC_TRAC_USER (default: apache)"
+ einfo " - EMAIL2TRAC_MTA_USER (default: nobody)"
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e "/^CFLAGS/s:=:&${CFLAGS} :" \
+ -e "s:\$(CC):& ${LDFLAGS} :" \
+ Makefile.in || die 'sed failed'
+}
+
+src_configure() {
+ econf --sysconfdir=/etc/${PN}/ \
+ --with-trac_user=${EMAIL2TRAC_TRAC_USER:-apache} \
+ --with-mta_user=${EMAIL2TRAC_MTA_USER:-nobody}
+}
diff --git a/app-misc/email2trac/email2trac-2.8.4.ebuild b/app-misc/email2trac/email2trac-2.8.4.ebuild
new file mode 100644
index 000000000000..1bd1ed0d7a30
--- /dev/null
+++ b/app-misc/email2trac/email2trac-2.8.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+DESCRIPTION="Utilities to convert emails to trac tickets"
+HOMEPAGE="https://oss.trac.surfsara.nl/email2trac"
+SRC_URI="ftp://ftp.sara.nl/pub/outgoing/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ <www-apps/trac-1.2[${PYTHON_USEDEP}]"
+
+pkg_setup() {
+ einfo "You can set the following variables in make.conf:"
+ einfo " - EMAIL2TRAC_TRAC_USER (default: apache)"
+ einfo " - EMAIL2TRAC_MTA_USER (default: nobody)"
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e "/^CFLAGS/s:=:&${CFLAGS} :" \
+ -e "s:\$(CC):& ${LDFLAGS} :" \
+ Makefile.in || die 'sed failed'
+}
+
+src_configure() {
+ econf --sysconfdir=/etc/${PN}/ \
+ --with-trac_user=${EMAIL2TRAC_TRAC_USER:-apache} \
+ --with-mta_user=${EMAIL2TRAC_MTA_USER:-nobody}
+}
diff --git a/app-misc/email2trac/metadata.xml b/app-misc/email2trac/metadata.xml
new file mode 100644
index 000000000000..07e1e7150826
--- /dev/null
+++ b/app-misc/email2trac/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>web-apps</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>lukas@dzunko.sk</email>
+ <name>Lukas Dzunko</name>
+ </maintainer>
+</pkgmetadata>