summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-11 08:28:21 +0200
committerJustin Lecher <jlec@gentoo.org>2015-08-11 08:30:09 +0200
commit233842f07c64898928e9ebb9df7ea4e66bfc9144 (patch)
treea5fef0c63a9863f9a15660c1e1072e3b6a10d966 /app-misc/fdupes/fdupes-9999.ebuild
parentmicrocode-data: add USE=initramfs #528712 (diff)
downloadgentoo-233842f07c64898928e9ebb9df7ea4e66bfc9144.tar.gz
gentoo-233842f07c64898928e9ebb9df7ea4e66bfc9144.tar.bz2
gentoo-233842f07c64898928e9ebb9df7ea4e66bfc9144.zip
app-misc/fdupes: Drop obsolete patch; add live version
Package-Manager: portage-2.2.20 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'app-misc/fdupes/fdupes-9999.ebuild')
-rw-r--r--app-misc/fdupes/fdupes-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/fdupes/fdupes-9999.ebuild b/app-misc/fdupes/fdupes-9999.ebuild
new file mode 100644
index 000000000000..9d51929dcefc
--- /dev/null
+++ b/app-misc/fdupes/fdupes-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic git-r3 toolchain-funcs
+
+MY_P="${PN}-${PV/_pre/-PR}"
+
+DESCRIPTION="Identify/delete duplicate files residing within specified directories"
+HOMEPAGE="https://github.com/adrianlopezroche/fdupes https://code.google.com/p/fdupes/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/adrianlopezroche/fdupes.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-makefile.patch
+
+ append-lfs-flags
+ tc-export CC
+}
+
+src_install() {
+ dobin fdupes
+ doman fdupes.1
+ dodoc CHANGES CONTRIBUTORS README TODO
+}