summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/grabcartoons/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/grabcartoons/files')
-rw-r--r--app-misc/grabcartoons/files/2.8.4-fix-install-paths.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/grabcartoons/files/2.8.4-fix-install-paths.patch b/app-misc/grabcartoons/files/2.8.4-fix-install-paths.patch
new file mode 100644
index 000000000000..420640b3de6c
--- /dev/null
+++ b/app-misc/grabcartoons/files/2.8.4-fix-install-paths.patch
@@ -0,0 +1,32 @@
+diff --git a/Makefile b/Makefile
+index a1f53e6..0a9bec4 100644
+--- a/Makefile
++++ b/Makefile
+@@ -23,9 +23,9 @@ all:
+
+ install:
+ mkdir -p -m 755 $(PREFIX)/bin
+- mkdir -p -m 755 $(PREFIX)/lib/grabcartoons/modules
+- install -m 755 grabcartoons.pl $(PREFIX)/bin
+- install -m 644 modules/*.pl $(PREFIX)/lib/grabcartoons/modules
++ mkdir -p -m 755 $(PREFIX)/share/grabcartoons/modules
++ install -m 755 grabcartoons.pl $(PREFIX)/bin/grabcartoons
++ install -m 644 modules/*.pl $(PREFIX)/share/grabcartoons/modules
+
+ test:
+ ./grabcartoons.pl $(V) "$(C)" > "$(OUT)"
+diff --git a/grabcartoons.pl b/grabcartoons.pl
+index cdc4152..d732301 100755
+--- a/grabcartoons.pl
++++ b/grabcartoons.pl
+@@ -38,8 +38,8 @@ $XTRN_CMD="$XTRN_PROG -q -O- $USER_AGENT_CMD";
+ # Where to load cartoon modules from
+ @MODULE_DIRS=("$FindBin::Bin/modules",
+ "$FindBin::RealBin/modules",
+- "$FindBin::Bin/../lib/grabcartoons/modules",
+- "$FindBin::RealBin/../lib/grabcartoons/modules",
++ "$FindBin::Bin/../share/grabcartoons/modules",
++ "$FindBin::RealBin/../share/grabcartoons/modules",
+ "$HOME/.grabcartoons/modules",
+ "$HOME/.grabcartoons",
+ @GRABCARTOONS_DIRS,