summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-07-04 15:04:18 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-07-08 20:06:37 +0200
commit272bfb060021a8f22d329bd8b6520ae06c6d5840 (patch)
tree49624b0546a81e9b324ebff876202ce82e46c8f1 /app-misc/grabcartoons
parentapp-misc/grabcartoons: EAPI8 bump (diff)
downloadgentoo-272bfb060021a8f22d329bd8b6520ae06c6d5840.tar.gz
gentoo-272bfb060021a8f22d329bd8b6520ae06c6d5840.tar.bz2
gentoo-272bfb060021a8f22d329bd8b6520ae06c6d5840.zip
app-misc/grabcartoons: version bump (v2.8.5)
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-misc/grabcartoons')
-rw-r--r--app-misc/grabcartoons/Manifest1
-rw-r--r--app-misc/grabcartoons/files/2.8.5-fix-install-paths.patch28
-rw-r--r--app-misc/grabcartoons/grabcartoons-2.8.5.ebuild31
3 files changed, 60 insertions, 0 deletions
diff --git a/app-misc/grabcartoons/Manifest b/app-misc/grabcartoons/Manifest
index 0e03ab816d43..d88db82a478f 100644
--- a/app-misc/grabcartoons/Manifest
+++ b/app-misc/grabcartoons/Manifest
@@ -1 +1,2 @@
DIST grabcartoons-2.8.4_p20141112.tar.gz 40998 BLAKE2B 616dde080c8e35548a527ede7c844fb23b733408bb21ce621065d698220111637b9cf8b044d56dabc6b0987123c656743a8c111b8e9c01cbeb589ed3bf35eb94 SHA512 6de81d151414ccbb7b00c2f472f0d811a7024c67a3c4bdc929babf2ff8990280ba1fde0851e4405dbc487c58e99f13a1dd07a0cd202099f6289dd0ed61296ee5
+DIST grabcartoons-2.8.5.tar.gz 48140 BLAKE2B 436c50f35f482b96d19cd5a61017fd0912674b7904ebaecc698806dbbf7faa7030424198568d0001c5be5ffe6567f34e877f11720dcf90c3a71332bd0ca9a470 SHA512 dc20e5ee04585c2a8279991025973ffe0805887a41195e8e5cb38dcd3652174a4f45174f7ecbbb7130a753f5ee63b87ad002ef1062406f95efb76c74186ef5ad
diff --git a/app-misc/grabcartoons/files/2.8.5-fix-install-paths.patch b/app-misc/grabcartoons/files/2.8.5-fix-install-paths.patch
new file mode 100644
index 000000000000..f3cb0c9fe3d9
--- /dev/null
+++ b/app-misc/grabcartoons/files/2.8.5-fix-install-paths.patch
@@ -0,0 +1,28 @@
+--- a/Makefile
++++ b/Makefile
+@@ -23,9 +23,9 @@
+
+ install:
+ mkdir -p -m 755 $(PREFIX)/bin
+- mkdir -p -m 755 $(PREFIX)/lib/grabcartoons/modules
+- install -m 755 grabcartoons.pl $(PREFIX)/bin
+- install -m 644 modules/*.pl $(PREFIX)/lib/grabcartoons/modules
++ mkdir -p -m 755 $(PREFIX)/share/grabcartoons/modules
++ install -m 755 grabcartoons.pl $(PREFIX)/bin/grabcartoons
++ install -m 644 modules/*.pl $(PREFIX)/share/grabcartoons/modules
+
+ test:
+ ./grabcartoons.pl $(V) "$(C)" > "$(OUT)"
+--- a/grabcartoons.pl
++++ b/grabcartoons.pl
+@@ -39,8 +39,8 @@
+ # Where to load cartoon modules from
+ @MODULE_DIRS=("$FindBin::Bin/modules",
+ "$FindBin::RealBin/modules",
+- "$FindBin::Bin/../lib/grabcartoons/modules",
+- "$FindBin::RealBin/../lib/grabcartoons/modules",
++ "$FindBin::Bin/../share/grabcartoons/modules",
++ "$FindBin::RealBin/../share/grabcartoons/modules",
+ "$HOME/.grabcartoons/modules",
+ "$HOME/.grabcartoons",
+ @GRABCARTOONS_DIRS,
diff --git a/app-misc/grabcartoons/grabcartoons-2.8.5.ebuild b/app-misc/grabcartoons/grabcartoons-2.8.5.ebuild
new file mode 100644
index 000000000000..bbd0173a4e06
--- /dev/null
+++ b/app-misc/grabcartoons/grabcartoons-2.8.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/zzamboni/grabcartoons.git"
+else
+ SRC_URI="https://github.com/zzamboni/grabcartoons/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Comic-summarizing utility"
+HOMEPAGE="https://zzamboni.org/code/grabcartoons/"
+
+LICENSE="BSD"
+SLOT="0"
+# Opens a web page, which is unacceptable during an emerge.
+RESTRICT="test"
+
+RDEPEND="
+ dev-lang/perl
+ virtual/perl-Getopt-Long"
+
+PATCHES=( "${FILESDIR}"/${PV}-fix-install-paths.patch )
+
+src_install() {
+ emake PREFIX="${ED}"/usr install
+ einstalldocs
+}