summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/regionset
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/regionset')
-rw-r--r--app-misc/regionset/Manifest2
-rw-r--r--app-misc/regionset/metadata.xml5
-rw-r--r--app-misc/regionset/regionset-0.1-r1.ebuild36
-rw-r--r--app-misc/regionset/regionset-0.2.ebuild41
4 files changed, 84 insertions, 0 deletions
diff --git a/app-misc/regionset/Manifest b/app-misc/regionset/Manifest
new file mode 100644
index 000000000000..3fa38e108e1f
--- /dev/null
+++ b/app-misc/regionset/Manifest
@@ -0,0 +1,2 @@
+DIST regionset-0.1.tar.gz 17095 SHA256 acb6f2ae259750fa4db5b9f7b64ae83d9d7ac6ad96b070d976ef1ef2a660a6d5 SHA512 19e1a681f6acc9f7da064432f893cd6736e3b54e5f0187025b9702a7301a982bc2f3948604e3bc9f7f15b20feb0dbc0424ad9727790cddb448b89189c1ce18c3 WHIRLPOOL 771d57b28a5045f15bb235135670cfc095a17045684bec5d9307c5a3bf81428f7ea528e75f99c67462b273b9cd60cac1d71db1abc0fb95c4a9bae0d18ce0ba62
+DIST regionset-0.2.tar.gz 19063 SHA256 0d5c86656efbb6c2efdeed730cff8e5109bd075139ce55542072cbda0ad2f7b9 SHA512 7d7fa92a2031a1d18032ba0979fe0ee27ff84c02977dc03df394383a2d562925b38eedfd478ee08d60e84de60914278f7880c10a43552345fe36af0c0fee6431 WHIRLPOOL 535699b2b35ea21bee4f71fd353bf3245ced1eb6a6e4377f6ec1e900bf802e62134b22d9d0d0a880a99d9f96decf5d70f37892aefa2a44c39e803a9ee5545f9b
diff --git a/app-misc/regionset/metadata.xml b/app-misc/regionset/metadata.xml
new file mode 100644
index 000000000000..bb93fa2613e7
--- /dev/null
+++ b/app-misc/regionset/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>media-optical</herd>
+</pkgmetadata>
diff --git a/app-misc/regionset/regionset-0.1-r1.ebuild b/app-misc/regionset/regionset-0.1-r1.ebuild
new file mode 100644
index 000000000000..6bcefe9e1e98
--- /dev/null
+++ b/app-misc/regionset/regionset-0.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Sets the region on DVD drives"
+HOMEPAGE="http://linvdr.org/projects/regionset/"
+SRC_URI="http://linvdr.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c dvd_udf.c || die
+}
+
+src_install() {
+ dosbin regionset || die
+ dodoc ChangeLog README || die
+}
+
+pkg_postinst() {
+ ewarn "By default regionset uses /dev/dvd, specify a different device"
+ ewarn "as a command line argument if you need to. You need write access"
+ ewarn "to do this, preferably as root."
+ ewarn
+ ewarn "Most drives can only have their region changed 4 or 5 times."
+ ewarn
+ ewarn "When you use regionset, you MUST have a cd or dvd in the drive"
+ ewarn "otherwise nasty things will happen to your drive's firmware."
+}
diff --git a/app-misc/regionset/regionset-0.2.ebuild b/app-misc/regionset/regionset-0.2.ebuild
new file mode 100644
index 000000000000..f4c5f51823fa
--- /dev/null
+++ b/app-misc/regionset/regionset-0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Sets the region on DVD drives"
+HOMEPAGE="http://linvdr.org/projects/regionset/"
+SRC_URI="http://linvdr.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ sed "/^\.IR/s@${PN}@${PF}@" -i ${PN}.8 || die
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c dvd_udf.c || die
+}
+
+src_install() {
+ dosbin ${PN}
+ doman ${PN}.8
+ dodoc debian/changelog README
+}
+
+pkg_postinst() {
+ ewarn "By default regionset uses /dev/dvd, specify a different device"
+ ewarn "as a command line argument if you need to. You need write access"
+ ewarn "to do this, preferably as root."
+ ewarn
+ ewarn "Most drives can only have their region changed 4 or 5 times."
+ ewarn
+ ewarn "When you use regionset, you MUST have a cd or dvd in the drive"
+ ewarn "otherwise nasty things will happen to your drive's firmware."
+}