summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/ttyrec
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/ttyrec')
-rw-r--r--app-misc/ttyrec/Manifest1
-rw-r--r--app-misc/ttyrec/files/ttyrec-1.0.8-ldflags.patch19
-rw-r--r--app-misc/ttyrec/metadata.xml14
-rw-r--r--app-misc/ttyrec/ttyrec-1.0.8-r1.ebuild30
4 files changed, 64 insertions, 0 deletions
diff --git a/app-misc/ttyrec/Manifest b/app-misc/ttyrec/Manifest
new file mode 100644
index 000000000000..4334db30229e
--- /dev/null
+++ b/app-misc/ttyrec/Manifest
@@ -0,0 +1 @@
+DIST ttyrec-1.0.8.tar.gz 8528 SHA256 ef5e9bf276b65bb831f9c2554cd8784bd5b4ee65353808f82b7e2aef851587ec SHA512 b7f6f4c78c5148dacc7058534d89f13fcf333ee9e099d4475135e9c15a99a8aed72bf4bd5954652a6bb044d11ad35b4cb8d07208a5349c79c811f68fde7e8611 WHIRLPOOL d8f51ea4c88082b0f272170fec7aed0fa14d153b145f17958dc6101b5e383bbf7dfc4c5ed9cdbac23c08cef6baf25f4b65f3db13f7575bae65bf9ca3f58d48e3
diff --git a/app-misc/ttyrec/files/ttyrec-1.0.8-ldflags.patch b/app-misc/ttyrec/files/ttyrec-1.0.8-ldflags.patch
new file mode 100644
index 000000000000..5b2393ce5393
--- /dev/null
+++ b/app-misc/ttyrec/files/ttyrec-1.0.8-ldflags.patch
@@ -0,0 +1,19 @@
+--- Makefile~ 2010-08-09 14:01:24.351716328 -0400
++++ Makefile 2010-08-09 14:00:45.981716329 -0400
+@@ -10,13 +10,13 @@
+ all: $(TARGET)
+
+ ttyrec: ttyrec.o io.o
+- $(CC) $(CFLAGS) -o ttyrec ttyrec.o io.o
++ $(CC) $(LDFLAGS) $(CFLAGS) -o ttyrec ttyrec.o io.o
+
+ ttyplay: ttyplay.o io.o
+- $(CC) $(CFLAGS) -o ttyplay ttyplay.o io.o
++ $(CC) $(LDFLAGS) $(CFLAGS) -o ttyplay ttyplay.o io.o
+
+ ttytime: ttytime.o io.o
+- $(CC) $(CFLAGS) -o ttytime ttytime.o io.o
++ $(CC) $(LDFLAGS) $(CFLAGS) -o ttytime ttytime.o io.o
+
+ clean:
+ rm -f *.o $(TARGET) ttyrecord *~
diff --git a/app-misc/ttyrec/metadata.xml b/app-misc/ttyrec/metadata.xml
new file mode 100644
index 000000000000..9d75d428f7db
--- /dev/null
+++ b/app-misc/ttyrec/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<longdescription>
+ttyrec is a tty recorder. Recorded data can be played back with the
+included ttyplay command. ttyrec is just a derivative of script
+command for recording timing information with microsecond accuracy as
+well. It can record emacs -nw, vi, lynx, or any programs running on
+tty.
+</longdescription>
+</pkgmetadata>
diff --git a/app-misc/ttyrec/ttyrec-1.0.8-r1.ebuild b/app-misc/ttyrec/ttyrec-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..c8b7fb28f029
--- /dev/null
+++ b/app-misc/ttyrec/ttyrec-1.0.8-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit base flag-o-matic toolchain-funcs
+
+DESCRIPTION="tty recorder"
+HOMEPAGE="http://namazu.org/~satoru/ttyrec/"
+SRC_URI="http://namazu.org/~satoru/ttyrec/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+# Bug 331843
+PATCHES=( "${FILESDIR}/${P}-ldflags.patch" )
+
+src_compile() {
+ # Bug 106530
+ [[ ${CHOST} != *-darwin* ]] && append-cppflags -DSVR4 -D_XOPEN_SOURCE=500
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ttyrec ttyplay ttytime
+ dodoc README
+ doman *.1
+}