summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-07-29 14:51:58 -0300
committerPacho Ramos <pacho@gentoo.org>2024-07-30 09:15:00 +0200
commit04b6b72a3a607cac19f7d2c46c02dd58cf942ce0 (patch)
tree5c99ccc3e943151cc6bd940d3f56b24f800e1e6c /app-misc
parentdev-libs/re2: Restrict abseil-cpp dep (diff)
downloadgentoo-04b6b72a3a607cac19f7d2c46c02dd58cf942ce0.tar.gz
gentoo-04b6b72a3a607cac19f7d2c46c02dd58cf942ce0.tar.bz2
gentoo-04b6b72a3a607cac19f7d2c46c02dd58cf942ce0.zip
app-misc/gnote: Bump to 46.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/37787 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gnote/Manifest1
-rw-r--r--app-misc/gnote/gnote-46.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
index 8f200741bc1e..0bcba1fd6ad3 100644
--- a/app-misc/gnote/Manifest
+++ b/app-misc/gnote/Manifest
@@ -1,2 +1,3 @@
DIST gnote-45.2.tar.xz 3248256 BLAKE2B ab687802aa6046556c579f1a11fb807398e69f2a256a8a63f50ea76bbcdfc8708ead603f25274b678912bb567c45e96bfe708ea2d56f9733ee1e6061195826bf SHA512 5380a50cfbf235b0007c47c3a1f4860ade599789e1746a7741fc672265698bb0717858bb39e5c0612d4d4e13040f1865674ddeda1427a4818aff508ba5ce8059
DIST gnote-46.0.tar.xz 3414728 BLAKE2B c53c4f1b5fa1c1dc0105f52736913ef3562a95e324fe4693e4b2729d5cc3ce47ab97ab8c22e2edb124a7cdd94c735b2b8417a02f88a9c23a310a027452fe8c3d SHA512 a56557ed1d5adb3d5416d8032218c953204737dd813e09c13875a084fd579145f94470b61d8c2322d01dba06ad0bb26d553e5009f5d3e10db284afc8b42e0b79
+DIST gnote-46.1.tar.xz 3414768 BLAKE2B cd0c942d97c06a275bce1dd6317ee4135ba8ea692b39d812de2c057ad2cb523965a701b62214d57c07bb7097293d5e946b19bd98d4629e98df42f13821afa27d SHA512 222cff949bb4403a4004210576d8f141fe4ee811da1ec8ca26a6d5474b4ec6d0fe49f9a8c8952e1228d200ca3b5c3e0eab18efb6787dda8d60608254c47d06a9
diff --git a/app-misc/gnote/gnote-46.1.ebuild b/app-misc/gnote/gnote-46.1.ebuild
new file mode 100644
index 000000000000..80e0527a52d9
--- /dev/null
+++ b/app-misc/gnote/gnote-46.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 meson readme.gentoo-r1
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.74:2[dbus]
+ >=dev-cpp/glibmm-2.74:2.68
+ >=dev-cpp/gtkmm-4.10.0:4.0
+ >=gui-libs/libadwaita-1
+ >=app-crypt/libsecret-0.8
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16
+ test? ( dev-libs/unittest++ )
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # Build system requires UnitTest++ >=1.5.1, but the .pc file doesn't
+ # specify a version
+ sed -i -e "/UnitTest++/ s/version: [^,]*,//" meson.build || die
+ if ! use test; then
+ sed -i -e "/unit_test_pp/ s/ = .*/ = disabler()/" meson.build || die
+ fi
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}